summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/swift-2.22.0.ebuild5
-rw-r--r--sys-cluster/swift/swift-2.23.1.ebuild5
-rw-r--r--sys-cluster/swift/swift-2019.2.9999.ebuild5
3 files changed, 6 insertions, 9 deletions
diff --git a/sys-cluster/swift/swift-2.22.0.ebuild b/sys-cluster/swift/swift-2.22.0.ebuild
index 9a409be64721..a69e441eb239 100644
--- a/sys-cluster/swift/swift-2.22.0.ebuild
+++ b/sys-cluster/swift/swift-2.22.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 )
inherit distutils-r1 eutils linux-info user
@@ -29,7 +29,6 @@ DEPEND="
RDEPEND="
${CDEPEND}
- >=dev-python/dnspython-1.14.0:0[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
>=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
diff --git a/sys-cluster/swift/swift-2.23.1.ebuild b/sys-cluster/swift/swift-2.23.1.ebuild
index 3e3deb94d7f2..1b2a5d5648c0 100644
--- a/sys-cluster/swift/swift-2.23.1.ebuild
+++ b/sys-cluster/swift/swift-2.23.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 )
inherit distutils-r1 eutils linux-info user
@@ -29,7 +29,6 @@ DEPEND="
RDEPEND="
${CDEPEND}
- >=dev-python/dnspython-1.15.0:0[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
>=dev-python/netifaces-0.8[${PYTHON_USEDEP}]
diff --git a/sys-cluster/swift/swift-2019.2.9999.ebuild b/sys-cluster/swift/swift-2019.2.9999.ebuild
index d90ce6aa21ec..c9ab6d0b2f70 100644
--- a/sys-cluster/swift/swift-2019.2.9999.ebuild
+++ b/sys-cluster/swift/swift-2019.2.9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+PYTHON_COMPAT=( python3_6 python3_7 )
inherit distutils-r1 eutils linux-info user
@@ -29,7 +29,6 @@ DEPEND="
RDEPEND="
${CDEPEND}
- >=dev-python/dnspython-1.15.0:0[$(python_gen_usedep 'python2_7')]
>=dev-python/eventlet-0.25.0[${PYTHON_USEDEP}]
>=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
>=dev-python/netifaces-0.8[${PYTHON_USEDEP}]