summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/swift')
-rw-r--r--sys-cluster/swift/Manifest1
-rw-r--r--sys-cluster/swift/swift-2.10.2-r1.ebuild117
2 files changed, 0 insertions, 118 deletions
diff --git a/sys-cluster/swift/Manifest b/sys-cluster/swift/Manifest
index 8307917b9f5a..c07798d1c2ad 100644
--- a/sys-cluster/swift/Manifest
+++ b/sys-cluster/swift/Manifest
@@ -1,3 +1,2 @@
-DIST swift-2.10.2.tar.gz 1899226 SHA256 310d0c762fc4bfae7beaa7a2a1d7cddcc7478e817f40b5322f9b7403772ce53b SHA512 9efcb764d18524327a1e3164bcf79fbeb25fefafb7b8cf24dda22477d5d08e9d9a76c851d3b51c86e22a02f30004d5421500150c42f5963e15882aec894e09e8 WHIRLPOOL ded7d106277a8c493a494633039b19eae6d8e3783d9a4a05f73ed75869402758e3650a292f6758334d45197d4995a08d6b6f1cc88fd68b6a005c3e026a460159
DIST swift-2.13.1.tar.gz 1940686 SHA256 785a098b93eceeb745fe85bafba8a8bda20a6aec64f76fb9e4d58bb671eb2bab SHA512 6f08239bbeebfd213d2d7bb23c83507bf033288bb5125f5fd7f37517d8b3ad0b050220c1ad03632c1ab4723a98a9068b146e38c360e6786159a6f8638f4d5d79 WHIRLPOOL 016ddab1201c0895b00b05a1c5a84628e3f69f306780e730ada5c8cae63e75c0959cec8be8c170abba42ea6b63bd32dd5ed6d9b6d37f72534c3a05f3c2cea4e4
DIST swift-2.15.1.tar.gz 2429235 SHA256 f7f03fe30f845655bb15dfc0850b13a38069a555ea2c23b2cf40924559031409 SHA512 8b01831c6c9103953a3dd61fbaf0b18287af0ee3a2e4be376352266e8442bea54bcd32e7e6de89376feb5e492c5b49f623b8eda5e5ea3e58fe0dcea1547bc1ac WHIRLPOOL 7debf87925504bbafa453e63493c2777b8dbd93b35e3ecc4454f300008f4870da45a9e77e0b8152b02d83bcdd07731dfd59fdd14e2bdd5116c967397b71a3a88
diff --git a/sys-cluster/swift/swift-2.10.2-r1.ebuild b/sys-cluster/swift/swift-2.10.2-r1.ebuild
deleted file mode 100644
index 30e158655806..000000000000
--- a/sys-cluster/swift/swift-2.10.2-r1.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 eutils linux-info user
-
-DESCRIPTION="A highly available, distributed, and eventually consistent object/blob store"
-HOMEPAGE="https://launchpad.net/swift"
-SRC_URI="https://tarballs.openstack.org/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="proxy account container object +memcached"
-REQUIRED_USE="|| ( proxy account container object )"
-
-CDEPEND="
- >=dev-python/pbr-0.8.0[${PYTHON_USEDEP}]
- <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-
-RDEPEND="
- ${CDEPEND}
- >=dev-python/dnspython-1.14.0:0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.5[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.0[${PYTHON_USEDEP}]
- !~dev-python/netifaces-0.10.1[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- >=dev-python/PyECLib-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.0[${PYTHON_USEDEP}]
- !~dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
- memcached? ( net-misc/memcached )
- net-misc/rsync[xattr]"
-
-pkg_pretend() {
- linux-info_pkg_setup
- CONFIG_CHECK="~EXT3_FS_XATTR ~SQUASHFS_XATTR ~CIFS_XATTR ~JFFS2_FS_XATTR
- ~TMPFS_XATTR ~UBIFS_FS_XATTR ~EXT2_FS_XATTR ~REISERFS_FS_XATTR ~EXT4_FS_XATTR
- ~ZFS"
- if linux_config_exists; then
- for module in ${CONFIG_CHECK}; do
- linux_chkconfig_present ${module} || ewarn "${module} needs to be enabled"
- done
- fi
-}
-
-pkg_setup() {
- enewuser swift
- enewgroup swift
-}
-
-src_prepare() {
- sed -i 's/xattr/pyxattr/g' swift.egg-info/requires.txt || die
- sed -i 's/xattr/pyxattr/g' requirements.txt || die
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-src_test () {
- # https://bugs.launchpad.net/swift/+bug/1249727
- find . \( -name test_wsgi.py -o -name test_locale.py -o -name test_utils.py \) -delete || die
- SKIP_PIP_INSTALL=1 PBR_VERSION=0.6.0 sh .unittests || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- keepdir /etc/swift
- insinto /etc/swift
-
- newins "etc/swift.conf-sample" "swift.conf"
- newins "etc/rsyncd.conf-sample" "rsyncd.conf"
- newins "etc/mime.types-sample" "mime.types-sample"
- newins "etc/memcache.conf-sample" "memcache.conf-sample"
- newins "etc/drive-audit.conf-sample" "drive-audit.conf-sample"
- newins "etc/dispersion.conf-sample" "dispersion.conf-sample"
-
- if use proxy; then
- newinitd "${FILESDIR}/swift-proxy.initd" "swift-proxy"
- newins "etc/proxy-server.conf-sample" "proxy-server.conf"
- if use memcached; then
- sed -i '/depend/a\
- need memcached' "${D}/etc/init.d/swift-proxy"
- fi
- fi
- if use account; then
- newinitd "${FILESDIR}/swift-account.initd" "swift-account"
- newins "etc/account-server.conf-sample" "account-server.conf"
- fi
- if use container; then
- newinitd "${FILESDIR}/swift-container.initd" "swift-container"
- newins "etc/container-server.conf-sample" "container-server.conf"
- fi
- if use object; then
- newinitd "${FILESDIR}/swift-object.initd" "swift-object"
- newins "etc/object-server.conf-sample" "object-server.conf"
- newins "etc/object-expirer.conf-sample" "object-expirer.conf"
- fi
-
- fowners root:swift "/etc/swift" || die "fowners failed"
- fperms 0750 /etc/swift
-}
-
-pkg_postinst() {
- elog "Openstack swift will default to using insecure http unless a"
- elog "certificate is created in /etc/swift/cert.crt and the associated key"
- elog "in /etc/swift/cert.key. These can be created with the following:"
- elog " * cd /etc/swift"
- elog " * openssl req -new -x509 -nodes -out cert.crt -keyout cert.key"
-}