summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-hppa64/binutils-hppa64-2.35.2.ebuild')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.35.2.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.35.2.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.35.2.ebuild
index 27d0f88efc67..97aa5834c6b7 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.35.2.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.35.2.ebuild
@@ -10,7 +10,7 @@ inherit eutils libtool flag-o-matic gnuconfig multilib toolchain-funcs
DESCRIPTION="Tools necessary to build programs"
HOMEPAGE="https://sourceware.org/binutils/"
LICENSE="GPL-3+"
-IUSE="default-gold doc +gold multitarget +nls +plugins static-libs test"
+IUSE="cet default-gold doc +gold multitarget +nls +plugins static-libs test"
REQUIRED_USE="default-gold? ( gold )"
# Variables that can be set here:
@@ -253,6 +253,11 @@ src_configure() {
# avoid automagic dependency on (currently prefix) systems
# systems with debuginfod library, bug #754753
--without-debuginfod
+
+ # Allow user to opt into CET for host libraries.
+ # Ideally we would like automagic-or-disabled here.
+ # But the check does not quite work on i686: bug #760926.
+ $(use_enable cet)
)
echo ./configure "${myconf[@]}"
"${S}"/configure "${myconf[@]}" || die