summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-9.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-9.0.9999.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-9.0.9999.ebuild b/sys-devel/clang-common/clang-common-9.0.9999.ebuild
new file mode 100644
index 000000000000..f8f3bfc80ba3
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-9.0.9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 git-r3
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_90"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+PDEPEND="sys-devel/clang:*"
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' utils/bash-autocomplete.sh
+}
+
+src_configure() { :; }
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ newbashcomp utils/bash-autocomplete.sh clang
+}