summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-runtime/clang-runtime-10.0.0_rc1.ebuild')
-rw-r--r--sys-devel/clang-runtime/clang-runtime-10.0.0_rc1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-10.0.0_rc1.ebuild b/sys-devel/clang-runtime/clang-runtime-10.0.0_rc1.ebuild
new file mode 100644
index 000000000000..2713d1f397ff
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-10.0.0_rc1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS=""
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+PROPERTIES="live"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"