summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gdb/gdb-7.10-r1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-7.10-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-devel/gdb/gdb-7.10-r1.ebuild b/sys-devel/gdb/gdb-7.10-r1.ebuild
index 9e9dde1288a0..8d9e6c989a8c 100644
--- a/sys-devel/gdb/gdb-7.10-r1.ebuild
+++ b/sys-devel/gdb/gdb-7.10-r1.ebuild
@@ -59,7 +59,7 @@ SLOT="0"
if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
+IUSE="+client expat lzma multitarget nls +python +server test vanilla"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
|| ( client server )
@@ -72,7 +72,7 @@ RDEPEND="server? ( !dev-util/gdbserver )
expat? ( dev-libs/expat )
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
- zlib? ( sys-libs/zlib )
+ sys-libs/zlib
)"
DEPEND="${RDEPEND}
app-arch/xz-utils
@@ -149,13 +149,16 @@ src_configure() {
# For gdb itself, it'll use the system version.
--disable-readline
--with-system-readline
+ # This only disables building in the zlib subdir.
+ # For gdb itself, it'll use the system version.
+ --without-zlib
+ --with-system-zlib
--with-separate-debug-dir="${EPREFIX}"/usr/lib/debug
$(use_with expat)
$(use_with lzma)
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPYTHON}")
- $(use_with zlib)
)
fi