summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/files/cmake/llvm-3.8-allow_custom_cmake_build_types.patch')
-rw-r--r--sys-devel/llvm/files/cmake/llvm-3.8-allow_custom_cmake_build_types.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/sys-devel/llvm/files/cmake/llvm-3.8-allow_custom_cmake_build_types.patch b/sys-devel/llvm/files/cmake/llvm-3.8-allow_custom_cmake_build_types.patch
new file mode 100644
index 000000000000..e42c08a8dc9e
--- /dev/null
+++ b/sys-devel/llvm/files/cmake/llvm-3.8-allow_custom_cmake_build_types.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt 2015-08-12 20:04:55.397881480 +0200
++++ b/CMakeLists.txt 2015-08-12 20:05:06.625741113 +0200
+@@ -152,11 +152,6 @@
+
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
+
+-if (CMAKE_BUILD_TYPE AND
+- NOT uppercase_CMAKE_BUILD_TYPE MATCHES "^(DEBUG|RELEASE|RELWITHDEBINFO|MINSIZEREL)$")
+- message(FATAL_ERROR "Invalid value for CMAKE_BUILD_TYPE: ${CMAKE_BUILD_TYPE}")
+-endif()
+-
+ set(LLVM_LIBDIR_SUFFIX "" CACHE STRING "Define suffix of library directory name (32/64)" )
+
+ # They are used as destination of target generators.