summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/m4/m4-1.4.18.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.18.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-devel/m4/m4-1.4.18.ebuild b/sys-devel/m4/m4-1.4.18.ebuild
index 1bb440ec6f2a..f249374d1d2b 100644
--- a/sys-devel/m4/m4-1.4.18.ebuild
+++ b/sys-devel/m4/m4-1.4.18.ebuild
@@ -3,6 +3,8 @@
EAPI="5"
+inherit eutils
+
DESCRIPTION="GNU macro processor"
HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
@@ -16,6 +18,11 @@ IUSE="examples"
DEPEND="app-arch/xz-utils"
RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-darwin17-printf-n.patch
+ default
+}
+
src_configure() {
# Disable automagic dependency over libsigsegv; see bug #278026
export ac_cv_libsigsegv=no