summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/m4/m4-1.4.18.ebuild')
-rw-r--r--sys-devel/m4/m4-1.4.18.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sys-devel/m4/m4-1.4.18.ebuild b/sys-devel/m4/m4-1.4.18.ebuild
deleted file mode 100644
index 378946733cae..000000000000
--- a/sys-devel/m4/m4-1.4.18.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils
-
-DESCRIPTION="GNU macro processor"
-HOMEPAGE="https://www.gnu.org/software/m4/m4.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples"
-
-# remember: cannot dep on autoconf since it needs us
-DEPEND="app-arch/xz-utils"
-RDEPEND=""
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-darwin17-printf-n.patch
- epatch "${FILESDIR}"/${P}-glibc228.patch #663924
- epatch_user
- default
-}
-
-src_configure() {
- # Disable automagic dependency over libsigsegv; see bug #278026
- export ac_cv_libsigsegv=no
-
- local myconf=""
- [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
- econf --enable-changeword ${myconf}
-}
-
-src_test() {
- [[ -d /none ]] && die "m4 tests will fail with /none/" #244396
- emake check
-}
-
-src_install() {
- default
- # autoconf-2.60 for instance, first checks gm4, then m4. If we don't have
- # gm4, it might find gm4 from outside the prefix on for instance Darwin
- use prefix && dosym /usr/bin/m4 /usr/bin/gm4
- if use examples ; then
- docinto examples
- dodoc examples/*
- rm -f "${ED}"/usr/share/doc/${PF}/examples/Makefile*
- fi
-}