summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/icecream/icecream-1.0.0-r2.ebuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/sys-devel/icecream/icecream-1.0.0-r2.ebuild b/sys-devel/icecream/icecream-1.0.0-r2.ebuild
index 187928a2290d..ead3cbfcfa51 100644
--- a/sys-devel/icecream/icecream-1.0.0-r2.ebuild
+++ b/sys-devel/icecream/icecream-1.0.0-r2.ebuild
@@ -13,13 +13,16 @@ SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="
+DEPEND="
sys-libs/libcap-ng
"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${DEPEND}
+ dev-util/shadowman
+"
S="${WORKDIR}/${MY_P}"
@@ -52,3 +55,15 @@ src_install() {
insinto /usr/share/shadowman/tools
newins - icecc <<<'/usr/libexec/icecc/bin'
}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && ${ROOT} == / ]]; then
+ eselect compiler-shadow remove icecc
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == / ]]; then
+ eselect compiler-shadow update icecc
+ fi
+}