summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fabric/mstflint')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index a1ba5d287b9c..ee065f4ba6ad 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1 +1,2 @@
DIST mstflint-4.10.0_p3.tar.gz 3208065 BLAKE2B 9d27bc41f3af4af2d430814a892bc26b302f4a57b2287cca4d5a64a37d7dd1b47e3f167b671be9ef1fadaf5dc51dff6094db811951ef1b5c6ad3ce746eb78546 SHA512 72077557f032bfa9c2c0b94f485b58c2d9efa955281997fed605e6351b1cfe73c46d8e4f293f93b58ebc4315d47b3dc3a4e8d72c8938647d34d291a2db89198f
+DIST mstflint-4.11.0_p5.tar.gz 3622665 BLAKE2B 119d1ca04eaf3ebc2e4b8175525fdc87079b27742013f210f8c38d2ac0e83b46c555e4b8b49d7f1562180473c0873456932939e942b1050e9c952a2e3172185a SHA512 c98f24acda519e62fd8db8e170c39c8ffe69b980bc2c9a167f20cfcb2575038648e463de0c7dfad3ddebe098b8a466640b7a125901c033f193a42ef1bfef00d8
diff --git a/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild b/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
new file mode 100644
index 000000000000..5b269215f95b
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.11.0_p5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="840c9c2193fe9145ab177b6e891fd535e1881b43"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="${HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3
+ sys-libs/zlib:=
+ inband? ( sys-fabric/libibmad )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl)
+ # /usr/bin/install: cannot create regular file '/var/tmp/portage/.../dev_mgt.py': File exists
+ sed -e 's:^dev_mgt_pylib_DATA = c_dev_mgt.so dev_mgt.py:dev_mgt_pylib_DATA = c_dev_mgt.so:' -i dev_mgt/Makefile || die
+}