summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/sof-firmware/sof-firmware-1.6.1.ebuild')
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-1.6.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/sof-firmware-1.6.1.ebuild b/sys-firmware/sof-firmware/sof-firmware-1.6.1.ebuild
new file mode 100644
index 000000000000..d62dacb90048
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-1.6.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/archive/stable-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+S=${WORKDIR}/sof-bin-stable-v${PV}
+
+src_compile() {
+ sed -i -e '1i #!/bin/bash\nset -e' go.sh || die
+}
+
+src_install() {
+ mkdir -p "${D}/lib/firmware/intel" || die
+ SOF_VERSION=v${PV} ROOT=${D} ${S}/go.sh || die
+}