summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/sof-firmware/sof-firmware-1.9.ebuild')
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-1.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/sof-firmware-1.9.ebuild b/sys-firmware/sof-firmware/sof-firmware-1.9.ebuild
new file mode 100644
index 000000000000..73dbc489b0e4
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-1.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S=${WORKDIR}/sof-bin-v${PV}
+
+QA_PREBUILT="/usr/bin/sof-logger"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" v${PV} || die
+}