summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/sof-firmware')
-rw-r--r--sys-firmware/sof-firmware/Manifest1
-rw-r--r--sys-firmware/sof-firmware/sof-firmware-1.9.3.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-firmware/sof-firmware/Manifest b/sys-firmware/sof-firmware/Manifest
index 2395475a2ffb..0fe746d0485a 100644
--- a/sys-firmware/sof-firmware/Manifest
+++ b/sys-firmware/sof-firmware/Manifest
@@ -1,2 +1,3 @@
DIST sof-firmware-1.6.1.tar.gz 3033953 BLAKE2B 0c33bd9a5d17c3b889219bf926d3619e3e448ff6b16e39b4caffe19e87c98d1227b303ebe80d185f93480ead29f37de39093f3e76f275df7836d3250ae47c566 SHA512 71acd34662ffd4d93f6111dfd046ed358184fdf24d0e118da43770aeee45bd15105b688bc5a569f2cb7941724ec822d2cfbab8a08e9caee1a77aa5763ac7b48e
+DIST sof-firmware-1.9.3.tar.gz 3710193 BLAKE2B d52fe0660c73c8e76fb60c492abe19f9e64b3064441880b84488193aa66710e49ef022c7cd1b8ece69d010aa5e416fbf4307a9c92d823525dbdc734194b0a98f SHA512 0c04bf47ecf65d3352b730e79968cb020211c274f64a3cc21e4c5e49c5a9706ab4d541aaea931e72c1bcc67fcde6387bc6bf952a33691aaab06e6b93aa73a024
DIST sof-firmware-1.9.tar.gz 3470302 BLAKE2B 597467915a658beda5611177c550b51a15720dfde23f1a55ea91217e7e809ff5c6417c6cc449e5d4a1732ffc03f9f817407951410646c9431ec189e8b141f60e SHA512 aee733381edb2150f2132c296e9151b1d6a71246e204b15c2394587c528286f730ceaf02002e1e58ccea0deba5e4ae81cb7a03efb858ac954633b0cfaec81a22
diff --git a/sys-firmware/sof-firmware/sof-firmware-1.9.3.ebuild b/sys-firmware/sof-firmware/sof-firmware-1.9.3.ebuild
new file mode 100644
index 000000000000..48bb1e61a889
--- /dev/null
+++ b/sys-firmware/sof-firmware/sof-firmware-1.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Sound Open Firmware (SOF) binary files"
+HOMEPAGE="https://www.sofproject.org https://github.com/thesofproject/sof https://github.com/thesofproject/sof-bin"
+SRC_URI="https://github.com/thesofproject/sof-bin/releases/download/v${PV}/sof-bin-v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/sof-bin-v${PV}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_PREBUILT="usr/bin/sof-logger usr/bin/sof-ctl usr/bin/sof-probes"
+
+src_install() {
+ dodir /lib/firmware/intel
+ dodir /usr/bin
+ FW_DEST="${D}/lib/firmware/intel" TOOLS_DEST="${D}/usr/bin" "${S}/install.sh" v${PV} || die
+}