summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/erofs-utils/erofs-utils-1.3.ebuild')
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/erofs-utils-1.3.ebuild b/sys-fs/erofs-utils/erofs-utils-1.3.ebuild
new file mode 100644
index 000000000000..00bd4e1de3bb
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+IUSE="fuse +lz4 selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse )
+ lz4? ( app-arch/lz4:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable lz4) \
+ $(use_with selinux) \
+ $(use_with uuid)
+}