summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.7.0.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.7.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.7.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.7.0.ebuild
new file mode 100644
index 000000000000..beabc5eb8e75
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.7.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit multilib
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+DEPEND="
+ sys-apps/util-linux
+ sys-libs/libselinux"
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf --prefix=/ --includedir=/usr/include
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
+ rm -f "${ED}"/$(get_libdir)/libf2fs_format.{,l}a
+}