summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/fswatch/fswatch-1.17.1.ebuild')
-rw-r--r--sys-fs/fswatch/fswatch-1.17.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/fswatch/fswatch-1.17.1.ebuild b/sys-fs/fswatch/fswatch-1.17.1.ebuild
new file mode 100644
index 000000000000..1ff71d7d6e2d
--- /dev/null
+++ b/sys-fs/fswatch/fswatch-1.17.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="cross-platform file change monitor with multiple backends"
+HOMEPAGE="https://github.com/emcrisostomo/fswatch"
+SRC_URI="https://github.com/emcrisostomo/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/13"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}