summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
index 9a3ccd0b8143..19db0eb6a84f 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit eutils toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs
DEB_VER="3"
@@ -40,6 +40,10 @@ src_prepare() {
use10() { usex $1 1 0 ; }
src_configure() {
+ # restore GNU89 inline semantics to
+ # emit function symbols, bug 595290
+ append-cflags -std=gnu89
+
# set up make command line variables in EMAKE_SQUASHFS_CONF
EMAKE_SQUASHFS_CONF=(
LZMA_XZ_SUPPORT=$(use10 lzma)