summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cachefilesd/Manifest1
-rw-r--r--sys-fs/cachefilesd/cachefilesd-0.10.10.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/cachefilesd/Manifest b/sys-fs/cachefilesd/Manifest
index 936836ae51ff..179c9cb79d35 100644
--- a/sys-fs/cachefilesd/Manifest
+++ b/sys-fs/cachefilesd/Manifest
@@ -1,2 +1,3 @@
+DIST cachefilesd-0.10.10.tar.bz2 26694 BLAKE2B c527a6283617ba53818e0cad1859544b1e66af1107b05d1f83904669425d31c5374f3c032b892c9d95892d02d9256bbd9b180f1d0b6b430f0cfa70440406ef9f SHA512 d7d816b5ef1fffe1272cb8c2e9cbd18c1393438afca250436a36a446c6a37303e7784057725a56be839e0489101190b563c4fc015fc4ff11baa8003121e5183a
DIST cachefilesd-0.10.5.tar 112640 BLAKE2B 2dadd76c522fb4fb7cf3fdf5dc69d43e7585c21d8988ad44714a0f30b110c2eebae855c71f61259c39e7018391c24a14e894bddfe4eaaa9766a93f912bf6ff6f SHA512 996e47de40cff4d2c0d265689ef3a33aee6ef0d0432a03d7428133c091e77b0e099bd1346b5638bf2d9df6bb47bce519491b420d5916a3211c4e04e158ad92e8
DIST cachefilesd-0.10.9.tar.bz2 26555 BLAKE2B da5df1d2c6715a7cc304b32842f00e69d356359abfae865cfc1b63b89e1149bcb48762ddf84d13f5d18b727d8e0693257d424e599c3874bbe842da9aed4a0cfe SHA512 06ab444a7df8ec37c15bc03554510f4acbb453e0730277f036abc5d61f9e377d90d9387dd5237ea481b95b1bf097b5992adce90ce971fe29760cc4c0d3c9cf34
diff --git a/sys-fs/cachefilesd/cachefilesd-0.10.10.ebuild b/sys-fs/cachefilesd/cachefilesd-0.10.10.ebuild
new file mode 100644
index 000000000000..629ffd58c2cf
--- /dev/null
+++ b/sys-fs/cachefilesd/cachefilesd-0.10.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Provides a caching directory on an already mounted filesystem"
+HOMEPAGE="https://people.redhat.com/~dhowells/fscache/"
+SRC_URI="https://people.redhat.com/~dhowells/fscache/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-cachefilesd )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.9-makefile.patch
+)
+
+src_prepare() {
+ default
+ if ! use selinux; then
+ sed -e '/^secctx/s:^:#:g' -i cachefilesd.conf || die
+ fi
+
+ tc-export CC
+ append-flags -fpie
+}
+
+src_install() {
+ default
+
+ if use selinux; then
+ insinto /usr/share/doc/${P}
+ doins -r selinux
+ fi
+
+ dodoc howto.txt
+
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+ newinitd "${FILESDIR}"/${PN}-3.init ${PN}
+
+ systemd_dounit ${PN}.service
+ systemd_newtmpfilesd "${FILESDIR}"/${PN}-tmpfiles.d ${PN}.conf
+}
+
+pkg_postinst() {
+ [[ -d /var/cache/fscache ]] && return
+ elog "Before CacheFiles can be used, a directory for local storage"
+ elog "must be created. The default configuration of /etc/cachefilesd.conf"
+ elog "uses /var/cache/fscache. The filesystem mounted there must support"
+ elog "extended attributes (mount -o user_xattr)."
+ echo ""
+ elog "Once that is taken care of, start the daemon, add -o ...,fsc"
+ elog "to the mount options of your network mounts, and let it fly!"
+}