summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mhddfs/files/mhddfs-0.1.39-xattr.patch26
-rw-r--r--sys-fs/mhddfs/mhddfs-0.1.39-r1.ebuild3
2 files changed, 28 insertions, 1 deletions
diff --git a/sys-fs/mhddfs/files/mhddfs-0.1.39-xattr.patch b/sys-fs/mhddfs/files/mhddfs-0.1.39-xattr.patch
new file mode 100644
index 000000000000..57a64281d653
--- /dev/null
+++ b/sys-fs/mhddfs/files/mhddfs-0.1.39-xattr.patch
@@ -0,0 +1,26 @@
+https://bugs.gentoo.org/648670
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+
+--- mhddfs-0.1.39/src/main.c
++++ mhddfs-0.1.39/src/main.c
+@@ -34,7 +34,7 @@
+ #include <utime.h>
+
+ #ifndef WITHOUT_XATTR
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #endif
+
+ #include "parse_options.h"
+--- mhddfs-0.1.39/src/tools.c
++++ mhddfs-0.1.39/src/tools.c
+@@ -32,7 +32,7 @@
+ #include <dirent.h>
+
+ #ifndef WITHOUT_XATTR
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #endif
+
+ #include "tools.h"
diff --git a/sys-fs/mhddfs/mhddfs-0.1.39-r1.ebuild b/sys-fs/mhddfs/mhddfs-0.1.39-r1.ebuild
index f161e79fa0f9..1c4db46a0fa0 100644
--- a/sys-fs/mhddfs/mhddfs-0.1.39-r1.ebuild
+++ b/sys-fs/mhddfs/mhddfs-0.1.39-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ DOCS=( ChangeLog README )
PATCHES=(
"${FILESDIR}/${PN}-respect-compiler-vars.patch"
"${FILESDIR}/${P}-segfault-fix.patch"
+ "${FILESDIR}/${P}-xattr.patch"
)
src_compile() {