summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/gentoo-kernel/gentoo-kernel-5.10.161.ebuild')
-rw-r--r--sys-kernel/gentoo-kernel/gentoo-kernel-5.10.161.ebuild131
1 files changed, 0 insertions, 131 deletions
diff --git a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.161.ebuild b/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.161.ebuild
deleted file mode 100644
index f57c34e8d52e..000000000000
--- a/sys-kernel/gentoo-kernel/gentoo-kernel-5.10.161.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit kernel-build toolchain-funcs
-
-MY_P=linux-${PV%.*}
-GENPATCHES_P=genpatches-${PV%.*}-$(( ${PV##*.} + 9 ))
-# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
-CONFIG_VER=5.10.12
-CONFIG_HASH=836165dd2dff34e4f2c47ca8f9c803002c1e6530
-GENTOO_CONFIG_VER=g1
-
-DESCRIPTION="Linux kernel built with Gentoo patches"
-HOMEPAGE="https://www.kernel.org/"
-SRC_URI+="
- https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
- https://dev.gentoo.org/~alicef/dist/genpatches/${GENPATCHES_P}.base.tar.xz
- https://dev.gentoo.org/~alicef/dist/genpatches/${GENPATCHES_P}.extras.tar.xz
- https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
- -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
- amd64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-x86_64-fedora.config
- -> kernel-x86_64-fedora.config.${CONFIG_VER}
- )
- arm64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-aarch64-fedora.config
- -> kernel-aarch64-fedora.config.${CONFIG_VER}
- )
- ppc64? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-ppc64le-fedora.config
- -> kernel-ppc64le-fedora.config.${CONFIG_VER}
- )
- x86? (
- https://src.fedoraproject.org/rpms/kernel/raw/${CONFIG_HASH}/f/kernel-i686-fedora.config
- -> kernel-i686-fedora.config.${CONFIG_VER}
- )
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc ppc64 x86"
-IUSE="debug hardened"
-REQUIRED_USE="arm? ( savedconfig )"
-
-RDEPEND="
- !sys-kernel/gentoo-kernel-bin:${SLOT}
-"
-BDEPEND="
- debug? ( dev-util/pahole )
-"
-PDEPEND="
- >=virtual/dist-kernel-${PV}
-"
-
-QA_FLAGS_IGNORED="
- usr/src/linux-.*/scripts/gcc-plugins/.*.so
- usr/src/linux-.*/vmlinux
-"
-
-src_prepare() {
- local PATCHES=(
- # meh, genpatches have no directory
- "${WORKDIR}"/*.patch
- )
- default
-
- local biendian=false
-
- # prepare the default config
- case ${ARCH} in
- amd64)
- cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
- ;;
- arm)
- return
- ;;
- arm64)
- cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
- biendian=true
- ;;
- hppa)
- return
- ;;
- ppc)
- # assume powermac/powerbook defconfig
- # we still package.use.force savedconfig
- cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
- ;;
- ppc64)
- cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
- biendian=true
- ;;
- x86)
- cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
- ;;
- *)
- die "Unsupported arch ${ARCH}"
- ;;
- esac
-
- local myversion="-gentoo-dist"
- use hardened && myversion+="-hardened"
- echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
- local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
-
- local merge_configs=(
- "${T}"/version.config
- "${dist_conf_path}"/base.config
- )
- use debug || merge_configs+=(
- "${dist_conf_path}"/no-debug.config
- )
- if use hardened; then
- merge_configs+=( "${dist_conf_path}"/hardened-base.config )
-
- tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
-
- if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
- merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
- fi
- fi
-
- # this covers ppc64 and aarch64_be only for now
- if [[ ${biendian} == true && $(tc-endian) == big ]]; then
- merge_configs+=( "${dist_conf_path}/big-endian.config" )
- fi
-
- kernel-build_merge_configs "${merge_configs[@]}"
-}