summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/linux-headers-3.18.ebuild6
-rw-r--r--sys-kernel/linux-headers/linux-headers-4.4.ebuild6
-rw-r--r--sys-kernel/linux-headers/linux-headers-4.9.ebuild6
3 files changed, 12 insertions, 6 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-3.18.ebuild b/sys-kernel/linux-headers/linux-headers-3.18.ebuild
index 9559d1170da3..ba6ba023e84d 100644
--- a/sys-kernel/linux-headers/linux-headers-3.18.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-3.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 bfin cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 openrisc ppc ppc64 s390 score sh sparc tile x86 xtensa"
@@ -25,7 +25,9 @@ src_unpack() {
}
src_prepare() {
- [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+ default
+
+ [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
}
src_install() {
diff --git a/sys-kernel/linux-headers/linux-headers-4.4.ebuild b/sys-kernel/linux-headers/linux-headers-4.4.ebuild
index fd5409695fa5..7179ff17febc 100644
--- a/sys-kernel/linux-headers/linux-headers-4.4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-4.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 bfin cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 s390 score sh sparc tile x86 xtensa"
@@ -25,7 +25,9 @@ src_unpack() {
}
src_prepare() {
- [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+ default
+
+ [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
}
src_install() {
diff --git a/sys-kernel/linux-headers/linux-headers-4.9.ebuild b/sys-kernel/linux-headers/linux-headers-4.9.ebuild
index ef17eaa51ae4..3b5fc0c8ba58 100644
--- a/sys-kernel/linux-headers/linux-headers-4.9.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-4.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 bfin cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 s390 score sh sparc tile x86 xtensa"
@@ -25,7 +25,9 @@ src_unpack() {
}
src_prepare() {
- [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+ default
+
+ [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
}
src_install() {