summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.5_p8.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index db0ce7d8bb62..bc26b21964ea 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -16,3 +16,4 @@ DIST pf-sources-5.5_p4.patch 1489666 BLAKE2B 3906d23f42d4943acf3e75a5b47d94b8084
DIST pf-sources-5.5_p5.patch 2147102 BLAKE2B 0f6aee4d3e59386e3acdf67ab7f931e45acb3d6d1b8aa39a914875da1bde2733d5b4bfc601635280f7f6fd0dcfbf1c6cdd77061a3e4230b128896da829b9e495 SHA512 7d60c3a18bec8642cc13594bdbb82c684d78d62636f9bbb9f2e791f7695476420c6d80256a4157a44e61f9d85c9405dd398587f935c33c77b8a2b92538855037
DIST pf-sources-5.5_p6.patch 2597110 BLAKE2B 7ab0a9bb5b1787cb2488e418bc3b45edf2348e60f118f90e47025d540367a93a49c87fd2362fc3bb3e84d89bd8d0c2b8f63c6f79e969813ce398578bdef9bcc2 SHA512 5530fd6e874ee5f0ac03e558c475790ac4e0ff79e98aa2df272d223d9a3cebf49a1e90a08751a37b694cd6b643040d0ececeea66a7a855194fbd33b448cdf3c9
DIST pf-sources-5.5_p7.patch 2978872 BLAKE2B 3b1e63dd0b3fdf1d880053576b8f4efa928292a7bde7f536ce551845bf2c33c74d008b3533428917a224cc0e959d5ebcd3bf09b2754f77183f6366b82a22d9eb SHA512 8da0e9085970dd5f3f641bcb9dff867db390dc49e278ef29ee6f84d2e99007d3403bc69f8e96280a6feccaf3f85731335a89e4888cf5df567429715baf5695fd
+DIST pf-sources-5.5_p8.patch 3180947 BLAKE2B 8170494363d949dce8b3de2a6121ec3c4bf2c0ecdba5e6a8e9d2c1e401a2ad9d67eb5ad35dea4749b176eee60398213962666637c9b344631b5c55d14ed6f879 SHA512 e21b810f52c2f31a6b1e21110a43be8d54695763780d04187b60ef2541bace779bbb978f7c6619b8433fd6fe6110cf69495a20bf142a64c9884518ca3265b2fd
diff --git a/sys-kernel/pf-sources/pf-sources-5.5_p8.ebuild b/sys-kernel/pf-sources/pf-sources-5.5_p8.ebuild
new file mode 100644
index 000000000000..2a683a5287d4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.5_p8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}