summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.10_p2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index c2bc0ee2038e..7b810f781737 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -11,6 +11,7 @@ DIST linux-5.7.tar.xz 112690468 BLAKE2B b2b71e231507429b178b6b89be546c4a3ee2757f
DIST linux-5.8.tar.xz 114459324 BLAKE2B 7bd97f8fa4527840754434414c07283e89731dc8ebb1e95fa5bc1469a60af1122582c0d3b6e262e77882f023190068df3537bd8b65964b3caa820bb2c8e579c7 SHA512 45a53ecf351096ef6e98242cca4228b8da9b9139ecc6963695791ea6fb7a9484a4e1c19dcca7ce7cbfdfa49de0451b70973bb078f12bdae9cbaddbc3f8092556
DIST linux-5.9.tar.xz 115507140 BLAKE2B e8d11472d63a9f8409ca12a2e8c97c6963a3d4516b5a398b627d6ece565584526f9b5a1377a2fa4bd184c09c7db94c987428bc5d52df0c788464a67e9e8d6dcb SHA512 d3d92ce4246bad74c9a784212f160d98449b1e8793970c2c308276568d852b8effe0528686bdb87d55d691f09a826abf7938d69bdd4759ce65ddd5c05ffe4eca
DIST pf-sources-5.10_p1.patch 2523647 BLAKE2B d31c389dbebd45068919f30680f63ab601d13a25b7b81daf1e7a0f46fd59c4803c644b8f53e944ec2078ef4c8a5e80ae71bcd1126161cd8432dbe3e742fc938f SHA512 c911efe868be9cb56814a50f08a79fa159e8b8225c3700e8367a4147d219fb82ea86ab21026a071afbc07da955d02b557eab53b4d5c7d6616580076b6822428d
+DIST pf-sources-5.10_p2.patch 2555927 BLAKE2B 69684df6616e243f5bda273ce4fd30300cde82355e3e71ef3f265bbc2fe2f680d035875ce76e836c0ee432692b69736ada54026bedbfa4423826260b5c3e05a1 SHA512 cdcaa01a9b89b935ee7b3035516c38b69ed38b897e4566adc132416fdb1953f965c33471192a3e0c85187af8edc2f0645d65e324d7b591fb4e3cabda4b05126c
DIST pf-sources-5.7_p7.patch 2471776 BLAKE2B c87c9a5f159967877a2858da1af919332aa9ccd49c2029950b31bcce592b9e802c4d5d5daf2f86929bf9318aaa455d879d3eba21904ab38e5615f05742934a98 SHA512 11c0f0021c1d67f65461a74598ed355309c5bdea8d8c94a8e59bcdff2a8320f9504a4457dd8adddcbfc85cd753bff6018ab9a093cfd7d70dcfee4a2f82110d30
DIST pf-sources-5.8_p7.patch 2546471 BLAKE2B 9eae65836ee0a4e67737462325753b6201c40fcf93f99a114e929f9557fb7bcf9ea619c2502f7824db6bdcf96c7a7640ad0cc1ff5dafa494a532e6f9ee4964b2 SHA512 0449f4ac292d8b0ac6222c273bc535acae5b1e8bdb9c6d196098d61de78fce6739911094bc8f710e4ef3ec187964ee8a146aa09c87f241e816ef5515272059eb
DIST pf-sources-5.9_p1.patch 35818 BLAKE2B c28c292b527c1116b927861dbcdfb948e1e7d30018ecacfa89425fb0b357f2a2cb93daa681ad6a940f936b255453770c743db2a95f8ad67bd6ab772febae7a76 SHA512 82f5583fdb8862a628265f188473fc2cfaaad1ffb06292248a69fc012058f743906aca7abcd88fa223e32f0a626748ae8111fa6858629182d0482989a0f7f725
diff --git a/sys-kernel/pf-sources/pf-sources-5.10_p2.ebuild b/sys-kernel/pf-sources/pf-sources-5.10_p2.ebuild
new file mode 100644
index 000000000000..f73be470724f
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.10_p2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux updates
+K_GENPATCHES_VER="3"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+# This is already patched via -pf patch set.
+UNIPATCH_EXCLUDE="1001_linux-5.10.1.patch"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ # kernel-2_src_prepare doesn't apply PATCHES().
+ default
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}