summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.32.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.32.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.32.ebuild b/sys-libs/glibc/glibc-2.32.ebuild
index 2a750041ae48..a53946fa5628 100644
--- a/sys-libs/glibc/glibc-2.32.ebuild
+++ b/sys-libs/glibc/glibc-2.32.ebuild
@@ -420,6 +420,11 @@ want__thread() {
use_multiarch() {
# Allow user to disable runtime arch detection in multilib.
use multiarch || return 1
+ # multiarch does not work on ppc with cache-block not equal to 128 bytes
+ # and breaks memset:
+ # https://sourceware.org/PR26522
+ # https://bugs.gentoo.org/737996
+ [[ $(tc-arch ${CTARGET}) == ppc ]] && return 1
# Make sure binutils is new enough to support indirect functions,
# #336792. This funky sed supports gold and bfd linkers.
local bver nver