summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libomp/libomp-14.0.6-r1.ebuild')
-rw-r--r--sys-libs/libomp/libomp-14.0.6-r1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-libs/libomp/libomp-14.0.6-r1.ebuild b/sys-libs/libomp/libomp-14.0.6-r1.ebuild
index 96e205375cbd..f3509fddd1fd 100644
--- a/sys-libs/libomp/libomp-14.0.6-r1.ebuild
+++ b/sys-libs/libomp/libomp-14.0.6-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake-multilib linux-info llvm llvm.org python-any-r1
+inherit flag-o-matic cmake-multilib linux-info llvm llvm.org python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
@@ -83,6 +83,8 @@ pkg_setup() {
}
multilib_src_configure() {
+ filter-lto # LTO causes issues in other packages building https://bugs.gentoo.org/870127
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"