summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libxcrypt')
-rw-r--r--sys-libs/libxcrypt/libxcrypt-4.4.12-r2.ebuild (renamed from sys-libs/libxcrypt/libxcrypt-4.4.12-r1.ebuild)9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.12-r1.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.12-r2.ebuild
index 0983a476edae..eb95be5ae561 100644
--- a/sys-libs/libxcrypt/libxcrypt-4.4.12-r1.ebuild
+++ b/sys-libs/libxcrypt/libxcrypt-4.4.12-r2.ebuild
@@ -20,10 +20,7 @@ DEPEND="system? (
)"
RDEPEND="${DEPEND}"
BDEPEND="sys-apps/findutils
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]')
- )"
+ test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
RESTRICT="!test? ( test )"
@@ -34,6 +31,10 @@ PATCHES=(
"${FILESDIR}/libxcrypt-4.4.12-multibuild.patch"
)
+python_check_deps() {
+ has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
MULTIBUILD_VARIANTS=(
$(usex compat 'xcrypt_compat' '')