summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tdb')
-rw-r--r--sys-libs/tdb/Manifest1
-rw-r--r--sys-libs/tdb/tdb-1.3.18.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index aa582c71a324..015bcbdb0fe1 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -2,4 +2,5 @@ DIST tdb-1.3.13.tar.gz 498002 BLAKE2B bf29b535acf3838942820a7dc841f635c457999d1a
DIST tdb-1.3.15.tar.gz 502627 BLAKE2B 44352033c421875f02491551dd8b1aa4a821a5e0070d6a32fc4f7a61535c98114325718c673fe163ad692f797aa2e9c26ca27a69a04459ba8340bbd8caacdfc5 SHA512 553246d5e7a7c22ea1b00962ac635d608f6d2344201862e796cad3b1a20610da1f5652ec9dbcb0187867fbd25f36247fcc34e9b4b2c3488c15d7202c9fb13bbb
DIST tdb-1.3.16.tar.gz 504330 BLAKE2B 686b6b3d026094a0219f2c5d76f7258cf2f96538f614fa9078ca00368ad64c4e93f2e184c98f3d6f480fec909d94105fdf527d96f3b4ea291d81bb63420d2a99 SHA512 7b17852986e48a32f3f8f303dd2a26503a69fcf7849f22f51483334c9abda9f189b521679e51b4ee5a80197a8f304a084dde0f56d92cfe953d3a4ede557526d2
DIST tdb-1.3.17.tar.gz 697224 BLAKE2B 6231c48924a2c164a6f55fc5cea0ce284fc5a34519e3cf26709322539118ed3dcdf21ecdeeb1a958a47c7502a625e66695f452d858a865965ce4fa60d65c55cd SHA512 ef25dad520a12d75e541802a46e418fe61ac691126600f24158cd5b95091b4c536ffc4d4aff6608cca087291fde0b86b44ff7b1a7837d816cd534e9688c39eff
+DIST tdb-1.3.18.tar.gz 697970 BLAKE2B a6dff8dbe444ce35f6470dae7da1b6719052fb2030fd5526157c67374b0f54fb815c8f799060ea2a811e85ce208f626f18a48df9169e3f45d3f92998246b81cd SHA512 9b856b2a5b2d852ff0048ba7b1700ea46b8dad5d4e94027472fdce9f1db4b5afba9aec127b7a4c2a38d4722c8e0ea78c1734d102fa134ac802eace6b24358034
DIST tdb-1.3.8.tar.gz 494106 BLAKE2B 3ac4418b642472859c37c20477ffcc255be6e435b84f59ee634fb5b80caa38aadbcc761fd2daf7c797f9d9a120dcf6e597b31306f8c67d3e890570dd94e4263f SHA512 9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b
diff --git a/sys-libs/tdb/tdb-1.3.18.ebuild b/sys-libs/tdb/tdb-1.3.18.ebuild
new file mode 100644
index 000000000000..13558afddb31
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.18.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}