summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/RyzenAdj/RyzenAdj-0.15.0.ebuild2
-rw-r--r--sys-power/nut/nut-2.8.2.ebuild2
-rw-r--r--sys-power/nut/nut-9999.ebuild2
-rw-r--r--sys-power/sandmann-bin/Manifest1
-rw-r--r--sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild59
-rw-r--r--sys-power/suspend/files/suspend-1.0_p20200924-Use-pkgconf-for-libgcrypt.patch18
-rw-r--r--sys-power/suspend/files/suspend-1.0_p20200924-fix-loff_t-for-musl.patch24
-rw-r--r--sys-power/suspend/suspend-1.0_p20200924.ebuild8
-rw-r--r--sys-power/tlp/Manifest1
-rw-r--r--sys-power/tlp/tlp-1.6.1.ebuild48
-rw-r--r--sys-power/tlp/tlp-1.7.0-r1.ebuild (renamed from sys-power/tlp/tlp-1.7.0.ebuild)20
11 files changed, 124 insertions, 61 deletions
diff --git a/sys-power/RyzenAdj/RyzenAdj-0.15.0.ebuild b/sys-power/RyzenAdj/RyzenAdj-0.15.0.ebuild
index c605ed842519..bee51f1a6cc4 100644
--- a/sys-power/RyzenAdj/RyzenAdj-0.15.0.ebuild
+++ b/sys-power/RyzenAdj/RyzenAdj-0.15.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/FlyGoat/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P
LICENSE="LGPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
DEPEND="sys-apps/pciutils"
RDEPEND="${DEPEND}"
diff --git a/sys-power/nut/nut-2.8.2.ebuild b/sys-power/nut/nut-2.8.2.ebuild
index a94d82dc5fab..6e1213d48302 100644
--- a/sys-power/nut/nut-2.8.2.ebuild
+++ b/sys-power/nut/nut-2.8.2.ebuild
@@ -61,7 +61,7 @@ BDEPEND="
RDEPEND="
${DEPEND}
monitor? ( $(python_gen_cond_dep '
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ dev-python/pyqt5[gui,widgets,${PYTHON_USEDEP}]
')
)
selinux? ( sec-policy/selinux-nut )
diff --git a/sys-power/nut/nut-9999.ebuild b/sys-power/nut/nut-9999.ebuild
index 9a6702956acb..6cfe1784c38b 100644
--- a/sys-power/nut/nut-9999.ebuild
+++ b/sys-power/nut/nut-9999.ebuild
@@ -61,7 +61,7 @@ BDEPEND="
RDEPEND="
${DEPEND}
monitor? ( $(python_gen_cond_dep '
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ dev-python/pyqt5[gui,widgets,${PYTHON_USEDEP}]
')
)
selinux? ( sec-policy/selinux-nut )
diff --git a/sys-power/sandmann-bin/Manifest b/sys-power/sandmann-bin/Manifest
index 9b57103ed034..af4f6453daa4 100644
--- a/sys-power/sandmann-bin/Manifest
+++ b/sys-power/sandmann-bin/Manifest
@@ -1 +1,2 @@
DIST sandmann-1.2.tar.xz 16868444 BLAKE2B b4e6bfefedc31af3b1fcb9c5b05349a23eb6150296dff6ee74a6626e6f6914a244bb7bb22ece4a28daa699f3291f1b7194307f1b524ed0c8ab924587e5b001f6 SHA512 44a3287f61361d0594988715ef8d302d772dbec40a50054c5091642cbba18ef006ddb59e52303f9482ddb66de6006ef340b3726be7486cdb40092302e5aa5501
+DIST sandmann-1.3.1.tar.xz 16884480 BLAKE2B 6e16eae03f7ab43d5c3807b43587dbf65047ed86196623748e499eba20d6347bd074ff6ed167f7301c7cfdc746654811428f16569bd1b8a6ebb3cb3b660cf7f0 SHA512 8aaead9ff9b711737eecff49edee042b32fdbc194b67f99a6bfbca6a8915442cd60d505ce070685915fa7aae6b0fecd7eb5c55096580bf3f8f525650eddbd8cc
diff --git a/sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild b/sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild
new file mode 100644
index 000000000000..62f852a65ff8
--- /dev/null
+++ b/sys-power/sandmann-bin/sandmann-bin-1.3.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-utils-2 systemd tmpfiles
+
+MY_PN=${PN%-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An autosuspend and wakeup daemon"
+HOMEPAGE="https://gitlab.com/flow/sandmann"
+SRC_URI="https://geekplace.eu/projects/${MY_PN}/archive/${MY_P}.tar.xz"
+
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-3+ LGPL-3"
+SLOT="0"
+
+KEYWORDS="amd64"
+
+# >=java-config-2.3.2 to get the libdir fix.
+RDEPEND="
+ acct-user/sandmann
+ >=dev-java/java-config-2.3.2
+ sys-apps/systemd
+ sys-auth/polkit
+ >=virtual/jre-17
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|^ExecStart=.*|ExecStart=/usr/bin/sandmann|' \
+ sandmann.service || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local my_emake_args=(
+ DESTDIR="${D}"
+ SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
+ TARGET_BINARY=
+ SOURCELESS_INSTALL=true
+ )
+
+ emake ${my_emake_args[@]} install
+
+ java-pkg_newjar out/main/assembly.dest/out.jar sandmann.jar
+ java-pkg_dolauncher sandmann
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ tmpfiles_process sandmann.conf
+}
diff --git a/sys-power/suspend/files/suspend-1.0_p20200924-Use-pkgconf-for-libgcrypt.patch b/sys-power/suspend/files/suspend-1.0_p20200924-Use-pkgconf-for-libgcrypt.patch
new file mode 100644
index 000000000000..ea77ab450e71
--- /dev/null
+++ b/sys-power/suspend/files/suspend-1.0_p20200924-Use-pkgconf-for-libgcrypt.patch
@@ -0,0 +1,18 @@
+diff --git a/configure.ac b/configure.ac
+index 5f3adb5..b7f21eb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -211,7 +211,12 @@ fi
+ if test "${enable_encrypt}" = "yes"; then
+ CONFIG_FEATURES="${CONFIG_FEATURES} encrypt"
+ AC_DEFINE([CONFIG_ENCRYPT], [1], [Define if encryption enabled])
+- AM_PATH_LIBGCRYPT([1:1.6.3], [], [AC_MSG_ERROR([Cannot locate >=libgcrypt-1.6.3])])
++ PKG_CONFIG="pkg-config --static"
++ PKG_CHECK_MODULES([LIBGCRYPT],
++ [libgcrypt >= 1.6.3],
++ ,
++ [AC_MSG_ERROR("Cannot locate >=libgcrypt-1.6.3")]
++ )
+ fi
+
+ if test "${enable_splashy}" = "yes"; then
diff --git a/sys-power/suspend/files/suspend-1.0_p20200924-fix-loff_t-for-musl.patch b/sys-power/suspend/files/suspend-1.0_p20200924-fix-loff_t-for-musl.patch
new file mode 100644
index 000000000000..37a77118f0c7
--- /dev/null
+++ b/sys-power/suspend/files/suspend-1.0_p20200924-fix-loff_t-for-musl.patch
@@ -0,0 +1,24 @@
+diff --git a/configure.ac b/configure.ac
+index 5f3adb5..0c544c8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -126,6 +126,7 @@ AC_CHECK_PROGS([M4], [m4])
+ AC_CHECK_PROG(PERL, perl, perl)
+
+ AC_SYS_LARGEFILE
++AC_USE_SYSTEM_EXTENSIONS
+
+ if test "${enable_create_device}" = "yes"; then
+ AC_CHECK_PROGS([MKNOD], [mknod])
+diff --git a/swsusp.h b/swsusp.h
+index 5f89902..6f4863e 100644
+--- a/swsusp.h
++++ b/swsusp.h
+@@ -9,6 +9,7 @@
+ *
+ */
+
++#include "config.h"
+ #include <stdint.h>
+ #include <linux/fs.h>
+ #include <linux/suspend_ioctls.h>
diff --git a/sys-power/suspend/suspend-1.0_p20200924.ebuild b/sys-power/suspend/suspend-1.0_p20200924.ebuild
index 56be503b7da8..b4d67354418a 100644
--- a/sys-power/suspend/suspend-1.0_p20200924.ebuild
+++ b/sys-power/suspend/suspend-1.0_p20200924.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,7 +32,11 @@ BDEPEND="
S="${WORKDIR}/${PN}"
-PATCHES=( "${WORKDIR}/${P}.patch" )
+PATCHES=(
+ "${WORKDIR}/${P}.patch"
+ "${FILESDIR}/${PN}-1.0_p20200924-Use-pkgconf-for-libgcrypt.patch"
+ "${FILESDIR}/${PN}-1.0_p20200924-fix-loff_t-for-musl.patch"
+ )
src_prepare() {
default
diff --git a/sys-power/tlp/Manifest b/sys-power/tlp/Manifest
index 20427738d53d..68e509588b5e 100644
--- a/sys-power/tlp/Manifest
+++ b/sys-power/tlp/Manifest
@@ -1,2 +1 @@
-DIST tlp-1.6.1.tar.gz 143688 BLAKE2B e7ddc8c792bf9911204556f6845da27e0c8722b5dc25b4b855c044a7d6b27662b6bad607532b631ea3766651f43321fda21ca1b51a01955d113ba838700d0182 SHA512 de88c4b4ae7d742eeec2bce7e43ccd99f971620541edc416471a46cb76a4f0c072821348d6c7f7fc44e7c70f2e3cde231d74546424ece533b2b2f531aee22b79
DIST tlp-1.7.0.tar.gz 151003 BLAKE2B 3dbd600921fe29d6adc4d195000087c969b4be8f8c3b6052cf411ad820f06c47e31e2cf93a0c33f822491f1cf2420fd6cf1193d45846b067975b4efbb3e5407e SHA512 db6777dff1b253f63941271d39b3785646ad15b4351a4a647ec748d9beabcc891b70d4070d0ce5b01919024e7560eac6ee858b720f8ec0a5535c51513ccf7a3d
diff --git a/sys-power/tlp/tlp-1.6.1.ebuild b/sys-power/tlp/tlp-1.6.1.ebuild
deleted file mode 100644
index 8c81e057e0fc..000000000000
--- a/sys-power/tlp/tlp-1.6.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit udev optfeature
-
-DESCRIPTION="Optimize laptop battery life"
-HOMEPAGE="https://linrunner.de/tlp/"
-SRC_URI="https://github.com/linrunner/TLP/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/TLP-${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-
-# It's uncertain if elogind/systemd is actually required, however, without the sleep
-# hooks working, which require one of them, it doesn't seem like this app is very useful.
-RDEPEND="
- dev-lang/perl
- virtual/udev
- || ( sys-auth/elogind sys-apps/systemd )
-"
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TLP_NO_INIT=1 \
- TLP_ELOD=/$(get_libdir)/elogind/system-sleep \
- TLP_WITH_ELOGIND=1 \
- TLP_WITH_SYSTEMD=1 \
- install install-man
-
- fperms 444 /usr/share/tlp/defaults.conf # manpage says this file should not be edited
- newinitd "${FILESDIR}/tlp.init" tlp
- keepdir /var/lib/tlp # created by Makefile, probably important
-}
-
-pkg_postinst() {
- udev_reload
-
- optfeature "disable Wake-on-LAN" sys-apps/ethtool
- optfeature "see disk drive health info in tlp-stat" sys-apps/smartmontools
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/sys-power/tlp/tlp-1.7.0.ebuild b/sys-power/tlp/tlp-1.7.0-r1.ebuild
index 6f8ae18fd40d..9932188670b3 100644
--- a/sys-power/tlp/tlp-1.7.0.ebuild
+++ b/sys-power/tlp/tlp-1.7.0-r1.ebuild
@@ -12,7 +12,7 @@ S="${WORKDIR}/TLP-${PV}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
# It's uncertain if elogind/systemd is actually required, however, without the sleep
# hooks working, which require one of them, it doesn't seem like this app is very useful.
@@ -25,17 +25,23 @@ RDEPEND="
src_install() {
# NOTE(JayF): TLP_WITH_ELOGIND/TLP_WITH_SYSTEMD are both only installing
# small init/config files.
- emake \
- DESTDIR="${D}" \
- TLP_NO_INIT=1 \
- TLP_ELOD=/$(get_libdir)/elogind/system-sleep \
- TLP_WITH_ELOGIND=1 \
- TLP_WITH_SYSTEMD=1 \
+ local myemakeargs=(
+ DESTDIR="${D}"
+ TLP_NO_INIT=1
+ TLP_ELOD=/usr/lib/elogind/system-sleep
+ TLP_WITH_ELOGIND=1
+ TLP_WITH_SYSTEMD=1
install install-man
+ )
+ emake "${myemakeargs[@]}"
fperms 444 /usr/share/tlp/defaults.conf # manpage says this file should not be edited
newinitd "${FILESDIR}/tlp.init" tlp
keepdir /var/lib/tlp # created by Makefile, probably important
+
+ # <elogind-255.5 used a different path (bug #939216), keep a compat symlink
+ # TODO: cleanup after 255.5 been stable for a few months
+ dosym {/usr/lib,/"$(get_libdir)"}/elogind/system-sleep/49-tlp-sleep
}
pkg_postinst() {