summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/upower/Manifest1
-rw-r--r--sys-power/upower/upower-0.99.9.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/sys-power/upower/Manifest b/sys-power/upower/Manifest
index ddb098c2a2dd..cc2e9525678f 100644
--- a/sys-power/upower/Manifest
+++ b/sys-power/upower/Manifest
@@ -1 +1,2 @@
DIST upower-0.99.8.tar.xz 448664 BLAKE2B e101e7d1b2aede77c1ed2da1fd23b87a95ccac8d901bd8d1f8bebcd5de7052a66f1840cf578a48453538e166aae56ef4bc6d3a2b85f7ba148ecac5cc0a486809 SHA512 dfd2960cae382195dfc7a703a02af298d9de55bc626cde2a1f97e7983842191ba9d99eb2044190214e792539e7d6c9d8e00b5aed17e5e86b04544e9ab90278b1
+DIST upower-0.99.9.tar.xz 448408 BLAKE2B 5fa2436f33c94cffb736d8e3fad433acf58954cf06ccd403a0361214be5afc45d79ea279f3c5c48dcd58b92ccaf995777c95987d1749fd8c8c8958317e439570 SHA512 45eb587b0e5ffcce88bad8c56bc5efa30559748913016a55d58313280f5159378e5fbb4a9842c3a6409257bb97822d235f96b03704268b8471455c93eb05fe2f
diff --git a/sys-power/upower/upower-0.99.9.ebuild b/sys-power/upower/upower-0.99.9.ebuild
new file mode 100644
index 000000000000..8219ae1eaea0
--- /dev/null
+++ b/sys-power/upower/upower-0.99.9.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit systemd xdg-utils
+
+DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
+HOMEPAGE="https://upower.freedesktop.org/"
+
+# No tarball released, use the same commit as Fedora
+#SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+COMMIT="2282c7c0e53fb31816b824c9d1f547e8"
+SRC_URI="https://gitlab.freedesktop.org/upower/upower/uploads/${COMMIT}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # based on SONAME of libupower-glib.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+# gtk-doc files are not available as prebuilt in the tarball
+IUSE="doc +introspection ios kernel_FreeBSD kernel_linux selinux"
+
+COMMON_DEPS="
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.34:2
+ sys-apps/dbus:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ kernel_linux? (
+ virtual/libusb:1
+ virtual/libgudev:=
+ virtual/udev
+ ios? (
+ >=app-pda/libimobiledevice-1:=
+ >=app-pda/libplist-1:=
+ )
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ selinux? ( sec-policy/selinux-devicekit )
+"
+DEPEND="${COMMON_DEPS}
+ doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+QA_MULTILIB_PATHS="usr/lib/${PN}/.*"
+
+DOCS=( AUTHORS HACKING NEWS README )
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ sed -i -e '/DISABLE_DEPRECATED/d' configure || die
+}
+
+src_configure() {
+ local backend
+
+ if use kernel_linux ; then
+ backend=linux
+ elif use kernel_FreeBSD ; then
+ backend=freebsd
+ else
+ backend=dummy
+ fi
+
+ local myeconfargs=(
+ --disable-static
+ --disable-tests
+ --enable-man-pages
+ --libexecdir="${EPREFIX}"/usr/lib/${PN}
+ --localstatedir="${EPREFIX}"/var
+ --with-backend=${backend}
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemdutildir="$(systemd_get_utildir)"
+ $(use_enable doc gtk-doc)
+ $(use_enable introspection)
+ $(use_with ios idevice)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ keepdir /var/lib/upower #383091
+}