summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/numad/numad-0.5.ebuild')
-rw-r--r--sys-process/numad/numad-0.5.ebuild21
1 files changed, 7 insertions, 14 deletions
diff --git a/sys-process/numad/numad-0.5.ebuild b/sys-process/numad/numad-0.5.ebuild
index e243f289db5f..926c416a8be7 100644
--- a/sys-process/numad/numad-0.5.ebuild
+++ b/sys-process/numad/numad-0.5.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit linux-info
-if [[ ${PV} = *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
- KEYWORDS="-arm -s390"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://pagure.io/numad.git"
+ inherit git-r3
else
- SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
+ HASH="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="mirror://gentoo/numad-0.5-${HASH:0:7}.tar.bz2"
KEYWORDS="amd64 -arm -s390 x86"
- S="${WORKDIR}/${PN}-334278f"
+ S="${WORKDIR}/${PN}-${HASH:0:7}"
fi
DESCRIPTION="The NUMA daemon that manages application locality"
@@ -22,9 +22,6 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
CONFIG_CHECK="~NUMA ~CPUSETS"
src_prepare() {
@@ -32,10 +29,6 @@ src_prepare() {
epatch
}
-src_configure() {
- :
-}
-
src_install() {
emake prefix="${ED}/usr" install
}