summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/Manifest1
-rw-r--r--sys-process/procps/files/procps-3.3.16-SC_ARG_MAX_sanity_check.patch60
-rw-r--r--sys-process/procps/files/procps-3.3.16-toprc_backwards_compatibility.patch71
-rw-r--r--sys-process/procps/procps-3.3.16-r2.ebuild87
-rw-r--r--sys-process/procps/procps-3.3.16-r3.ebuild88
5 files changed, 0 insertions, 307 deletions
diff --git a/sys-process/procps/Manifest b/sys-process/procps/Manifest
index 7c9362d1b1cc..f9a2cf039d39 100644
--- a/sys-process/procps/Manifest
+++ b/sys-process/procps/Manifest
@@ -1,2 +1 @@
-DIST procps-ng-3.3.16.tar.xz 859736 BLAKE2B fbacc1edb0711cda0fecbf5f589c8cc18bd74f0430866e946f7c4612b78f383b9299840ab7fa5bbc65c581cc9484dbb37b111c493cf88f55ba247a343fd0c80d SHA512 d83da472df256b188c32082632202e7f8ebd1b161082387760876ae34d50221b3682299a2816a7d6a29afb40322743c31b87d92ca299c2944a6b55e50736d367
DIST procps-ng-3.3.17.tar.xz 1008428 BLAKE2B 43aa1a21d4f0725b1c02457f343cf1fc66bc1771b25c6eaf689c9775c190e90545bfac1729f027abc4d3d13de37ffac4828554b5b25e12bcf6af9540de1695f3 SHA512 59e9a5013430fd9da508c4655d58375dc32e025bb502bb28fb9a92a48e4f2838b3355e92b4648f7384b2050064d17079bf4595d889822ebb5030006bc154a1a7
diff --git a/sys-process/procps/files/procps-3.3.16-SC_ARG_MAX_sanity_check.patch b/sys-process/procps/files/procps-3.3.16-SC_ARG_MAX_sanity_check.patch
deleted file mode 100644
index 1b85c2c855f1..000000000000
--- a/sys-process/procps/files/procps-3.3.16-SC_ARG_MAX_sanity_check.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From bb96fc42956c9ed926a1b958ab715f8b4a663dec Mon Sep 17 00:00:00 2001
-From: Craig Small <csmall@dropbear.xyz>
-Date: Sun, 5 Jan 2020 15:05:55 +1100
-Subject: [PATCH] pgrep: check sanity of SC_ARG_MAX
-
-A kernel change means we cannot trust what sysconf(SC_ARG_MAX)
-returns. We clamp it so its more than 4096 and less than 128*1024
-which is what findutils does.
-
-References:
- procps-ng/procps#152
- https://git.savannah.gnu.org/cgit/findutils.git/tree/lib/buildcmd.c#n535
- https://lwn.net/Articles/727862/
----
- pgrep.c | 22 +++++++++++++++++++++-
- 1 file changed, 21 insertions(+), 1 deletion(-)
-
-diff --git a/pgrep.c b/pgrep.c
-index 01563db..bde7448 100644
---- a/pgrep.c
-+++ b/pgrep.c
-@@ -485,6 +485,26 @@ static regex_t * do_regcomp (void)
- return preg;
- }
-
-+/*
-+ * SC_ARG_MAX used to return the maximum size a command line can be
-+ * however changes to the kernel mean this can be bigger than we can
-+ * alloc. Clamp it to 128kB like xargs and friends do
-+ * Should also not be smaller than POSIX_ARG_MAX which is 4096
-+ */
-+static size_t get_arg_max(void)
-+{
-+#define MIN_ARG_SIZE 4096u
-+#define MAX_ARG_SIZE (128u * 1024u)
-+
-+ size_t val = sysconf(_SC_ARG_MAX);
-+
-+ if (val < MIN_ARG_SIZE)
-+ val = MIN_ARG_SIZE;
-+ if (val > MAX_ARG_SIZE)
-+ val = MAX_ARG_SIZE;
-+
-+ return val;
-+}
- static struct el * select_procs (int *num)
- {
- PROCTAB *ptp;
-@@ -497,7 +517,7 @@ static struct el * select_procs (int *num)
- regex_t *preg;
- pid_t myself = getpid();
- struct el *list = NULL;
-- long cmdlen = sysconf(_SC_ARG_MAX) * sizeof(char);
-+ long cmdlen = get_arg_max() * sizeof(char);
- char *cmdline = xmalloc(cmdlen);
- char *cmdsearch = xmalloc(cmdlen);
- char *cmdoutput = xmalloc(cmdlen);
---
-GitLab
-
diff --git a/sys-process/procps/files/procps-3.3.16-toprc_backwards_compatibility.patch b/sys-process/procps/files/procps-3.3.16-toprc_backwards_compatibility.patch
deleted file mode 100644
index 19721205dfe7..000000000000
--- a/sys-process/procps/files/procps-3.3.16-toprc_backwards_compatibility.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 5cd29e5093efa3c6ee9c5310b64347f1d54b707d Mon Sep 17 00:00:00 2001
-From: Jim Warner <james.warner@comcast.net>
-Date: Sat, 15 Feb 2020 00:00:00 -0600
-Subject: [PATCH] top: restore configuration file backward compatibility
-
-The Debian bug referenced below has nothing to do with
-locales. In fact, top was made locale independent back
-in release 3.3.13 (April, 2018). However, that bug did
-reveal some misplaced logic which this patch corrects.
-
-Prompted by the Qualys audit, all rcfile field strings
-were checked for potential duplicates which could only
-have resulted from some user's manual/malicious edits.
-
-Unfortunately, that code was executed before top had a
-chance to enforce the proper/maximum string length (in
-the event an extremely old rcfile had just been read).
-This created some potential string overrun references.
-
-In top's original 3.3.15 implementation, the potential
-overrun extended for 15 characters. That is the number
-of field characters added with 3.3.9 (December, 2013).
-But, since strchr() was used, no error exit was taken.
-
-In the revised 3.3.16 implementation, the strchr() was
-replaced with '&w->rc.fieldscur[n]'. This held overrun
-to a single position while producing an error message.
-
-So, this commit just moves that logic to a point where
-fieldscur is guaranteed to be longer than EU_MAXPFLGS.
-
-Reference(s):
-https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=951335
-. revised 3.3.16 validation logic
-commit 291d98ee5036567f93d21bc11142b0a7e2ee70ae
-. original 3.3.15 validation logic
-commit fdb58974e24c025a1f866f324c62f1d8f96234f8
-
-Signed-off-by: Jim Warner <james.warner@comcast.net>
----
-diff --git a/top/top.c b/top/top.c
-index 63ec5fe..b4fe21e 100644
---- a/top/top.c
-+++ b/top/top.c
-@@ -3939,11 +3939,6 @@ static const char *configs_file (FILE *fp, const char *name, float *delay) {
- // too bad fscanf is not as flexible with his format string as snprintf
- #error Hey, fix the above fscanf 'PFLAGSSIZ' dependency !
- #endif
-- // ensure there's been no manual alteration of fieldscur
-- for (n = 0 ; n < EU_MAXPFLGS; n++) {
-- if (&w->rc.fieldscur[n] != strrchr(w->rc.fieldscur, w->rc.fieldscur[n]))
-- return p;
-- }
- // be tolerant of missing release 3.3.10 graph modes additions
- if (3 > fscanf(fp, "\twinflags=%d, sortindx=%d, maxtasks=%d, graph_cpus=%d, graph_mems=%d\n"
- , &w->rc.winflags, &w->rc.sortindx, &w->rc.maxtasks, &w->rc.graph_cpus, &w->rc.graph_mems))
-@@ -3989,6 +3984,11 @@ static const char *configs_file (FILE *fp, const char *name, float *delay) {
- return p;
- break;
- }
-+ // ensure there's been no manual alteration of fieldscur
-+ for (n = 0 ; n < EU_MAXPFLGS; n++) {
-+ if (&w->rc.fieldscur[n] != strrchr(w->rc.fieldscur, w->rc.fieldscur[n]))
-+ return p;
-+ }
- #ifndef USE_X_COLHDR
- OFFw(w, NOHIFND_xxx | NOHISEL_xxx);
- #endif
---
-2.24.1
-
diff --git a/sys-process/procps/procps-3.3.16-r2.ebuild b/sys-process/procps/procps-3.3.16-r2.ebuild
deleted file mode 100644
index fc0db915eeff..000000000000
--- a/sys-process/procps/procps-3.3.16-r2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal usr-ldscript
-
-DESCRIPTION="Standard informational utilities and process-handling tools"
-HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
-SRC_URI="mirror://sourceforge/${PN}-ng/${PN}-ng-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/8" # libprocps.so
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- elogind? ( sys-auth/elogind )
- ncurses? ( >=sys-libs/ncurses-5.7-r7:=[unicode?] )
- selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
- systemd? ( sys-apps/systemd[${MULTILIB_USEDEP}] )
-"
-DEPEND="${COMMON_DEPEND}
- elogind? ( virtual/pkgconfig )
- ncurses? ( virtual/pkgconfig )
- systemd? ( virtual/pkgconfig )
- test? ( dev-util/dejagnu )"
-RDEPEND="
- ${COMMON_DEPEND}
- kill? (
- !sys-apps/coreutils[kill]
- !sys-apps/util-linux[kill]
- )
- !<app-i18n/man-pages-de-2.12-r1
- !<app-i18n/man-pages-pl-0.7-r1
-"
-
-S="${WORKDIR}/${PN}-ng-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.11-sysctl-manpage.patch # 565304
- "${FILESDIR}"/${PN}-3.3.12-proc-tests.patch # 583036
-
- # Upstream fixes
- "${FILESDIR}"/${P}-toprc_backwards_compatibility.patch #711676
-)
-
-multilib_src_configure() {
- # http://www.freelists.org/post/procps/PATCH-enable-transparent-large-file-support
- append-lfs-flags #471102
- local myeconfargs=(
- $(multilib_native_use_with elogind) # No elogind multilib support
- $(multilib_native_use_enable kill)
- $(multilib_native_use_enable modern-top)
- $(multilib_native_use_with ncurses)
- $(use_enable nls)
- $(use_enable selinux libselinux)
- $(use_enable static-libs static)
- $(use_with systemd)
- $(use_enable unicode watch8bit)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- emake check </dev/null #461302
-}
-
-multilib_src_install() {
- default
- #dodoc sysctl.conf
-
- if multilib_is_native_abi ; then
- dodir /bin
- mv "${ED}"/usr/bin/ps "${ED}"/bin/ || die
- if use kill; then
- mv "${ED}"/usr/bin/kill "${ED}"/bin/ || die
- fi
-
- gen_usr_ldscript -a procps
- fi
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f -name '*.la' -delete || die
-}
diff --git a/sys-process/procps/procps-3.3.16-r3.ebuild b/sys-process/procps/procps-3.3.16-r3.ebuild
deleted file mode 100644
index 96f077659aef..000000000000
--- a/sys-process/procps/procps-3.3.16-r3.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic multilib-minimal usr-ldscript
-
-DESCRIPTION="Standard informational utilities and process-handling tools"
-HOMEPAGE="http://procps-ng.sourceforge.net/ https://gitlab.com/procps-ng/procps"
-SRC_URI="mirror://sourceforge/${PN}-ng/${PN}-ng-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/8" # libprocps.so
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="elogind +kill modern-top +ncurses nls selinux static-libs systemd test unicode"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- elogind? ( sys-auth/elogind )
- ncurses? ( >=sys-libs/ncurses-5.7-r7:=[unicode?] )
- selinux? ( sys-libs/libselinux[${MULTILIB_USEDEP}] )
- systemd? ( sys-apps/systemd[${MULTILIB_USEDEP}] )
-"
-DEPEND="${COMMON_DEPEND}
- elogind? ( virtual/pkgconfig )
- ncurses? ( virtual/pkgconfig )
- systemd? ( virtual/pkgconfig )
- test? ( dev-util/dejagnu )"
-RDEPEND="
- ${COMMON_DEPEND}
- kill? (
- !sys-apps/coreutils[kill]
- !sys-apps/util-linux[kill]
- )
- !<app-i18n/man-pages-de-2.12-r1
- !<app-i18n/man-pages-pl-0.7-r1
-"
-
-S="${WORKDIR}/${PN}-ng-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.11-sysctl-manpage.patch # 565304
- "${FILESDIR}"/${PN}-3.3.12-proc-tests.patch # 583036
-
- # Upstream fixes
- "${FILESDIR}"/${P}-toprc_backwards_compatibility.patch #711676
- "${FILESDIR}"/${P}-SC_ARG_MAX_sanity_check.patch #767217
-)
-
-multilib_src_configure() {
- # http://www.freelists.org/post/procps/PATCH-enable-transparent-large-file-support
- append-lfs-flags #471102
- local myeconfargs=(
- $(multilib_native_use_with elogind) # No elogind multilib support
- $(multilib_native_use_enable kill)
- $(multilib_native_use_enable modern-top)
- $(multilib_native_use_with ncurses)
- $(use_enable nls)
- $(use_enable selinux libselinux)
- $(use_enable static-libs static)
- $(use_with systemd)
- $(use_enable unicode watch8bit)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- emake check </dev/null #461302
-}
-
-multilib_src_install() {
- default
- #dodoc sysctl.conf
-
- if multilib_is_native_abi ; then
- dodir /bin
- mv "${ED}"/usr/bin/ps "${ED}"/bin/ || die
- if use kill ; then
- mv "${ED}"/usr/bin/kill "${ED}"/bin/ || die
- fi
-
- gen_usr_ldscript -a procps
- fi
-}
-
-multilib_src_install_all() {
- find "${ED}" -type f -name '*.la' -delete || die
-}