summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/usbtop/usbtop-1.0.ebuild')
-rw-r--r--sys-process/usbtop/usbtop-1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/usbtop/usbtop-1.0.ebuild b/sys-process/usbtop/usbtop-1.0.ebuild
new file mode 100644
index 000000000000..7b8e3d1fcb94
--- /dev/null
+++ b/sys-process/usbtop/usbtop-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap:=[usb]
+ dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}