summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/usbtop')
-rw-r--r--sys-process/usbtop/Manifest1
-rw-r--r--sys-process/usbtop/usbtop-1.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-process/usbtop/Manifest b/sys-process/usbtop/Manifest
index 0eac4db7eb22..ddaf1a0ad299 100644
--- a/sys-process/usbtop/Manifest
+++ b/sys-process/usbtop/Manifest
@@ -1 +1,2 @@
DIST usbtop-0.2.tar.gz 10828 BLAKE2B d595fda23adee6778060c25176d1951250bb45cc25ea8040661222736c63aa356605ec8ca52b71e7142cf0f8e7807a77a54fffbc54165178f44af63dfb5ba712 SHA512 43a4512abcff6107ac7a56d65ee19c2b17f4aeb9d38e42e630d724c6744c7d23c85d2c66325c0e6b50404431312754646f1290202fa51f3dee1f94a9d211ba25
+DIST usbtop-1.0.tar.gz 626770 BLAKE2B 4f14e1e8d926ce7f6ffd1a276871d7d9072979d844a55e477c402bcac343a3cc14faebbfd3886b386a48b01399bcb748fb843453a0eee48b8e09578841eab356 SHA512 bc2003c1085fae238d99347bbf3caa1da7e44aa8f5b07abbde3f96b4124b301bbbc896f7b5e341665db1cdba44a59752884e3b9fe3a6104ef804aa94c510a5c0
diff --git a/sys-process/usbtop/usbtop-1.0.ebuild b/sys-process/usbtop/usbtop-1.0.ebuild
new file mode 100644
index 000000000000..7b8e3d1fcb94
--- /dev/null
+++ b/sys-process/usbtop/usbtop-1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils linux-info
+
+DESCRIPTION="utility that shows an estimated instantaneous bandwidth on USB buses and devices"
+HOMEPAGE="https://github.com/aguinet/usbtop"
+SRC_URI="https://github.com/aguinet/usbtop/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap:=[usb]
+ dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="~USB_MON"
+ check_extra_config
+ fi
+}