summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/tini/tini-0.13.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-process/tini/tini-0.13.0.ebuild b/sys-process/tini/tini-0.13.0.ebuild
index 98488eb20f54..826d43240347 100644
--- a/sys-process/tini/tini-0.13.0.ebuild
+++ b/sys-process/tini/tini-0.13.0.ebuild
@@ -7,7 +7,7 @@ EAPI=6
inherit cmake-utils flag-o-matic
DESCRIPTION="A tiny but valid init for containers"
-HOMEPAGE="https://github.com/krallin/${PN}"
+HOMEPAGE="https://github.com/krallin/tini"
SRC_URI="https://github.com/krallin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
@@ -18,6 +18,12 @@ IUSE="+args static"
# vim-core is needed just for the xxd program
DEPEND="app-editors/vim-core"
+src_prepare() {
+ default
+ # Do not strip binary
+ sed -i -e 's/-Wl,-s")$/")/' CMakeLists.txt || die
+}
+
src_configure() {
local mycmakeargs=()
use args || mycmakeargs+=(-DMINIMAL=ON)