summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/opencl/opencl-0.ebuild')
-rw-r--r--virtual/opencl/opencl-0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/virtual/opencl/opencl-0.ebuild b/virtual/opencl/opencl-0.ebuild
new file mode 100644
index 000000000000..4fff3861bd62
--- /dev/null
+++ b/virtual/opencl/opencl-0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Until ATI's SDK is in the tree, nvidia is the only
+# viable provider #392179 #257626
+
+EAPI="4"
+
+DESCRIPTION="Virtual for OpenCL implementations"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="amd64 x86"
+#CARDS=( fglrx nvidia )
+CARDS=( nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+REQUIRED_USE="|| ( ${IUSE} )"
+
+# video_cards_fglrx? ( x11-drivers/ati-drivers[opencl] )
+RDEPEND="|| (
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers >=dev-util/nvidia-cuda-toolkit-3.1 )
+ )"