summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/wine')
-rw-r--r--virtual/wine/metadata.xml16
-rw-r--r--virtual/wine/wine-0-r4.ebuild31
2 files changed, 47 insertions, 0 deletions
diff --git a/virtual/wine/metadata.xml b/virtual/wine/metadata.xml
new file mode 100644
index 000000000000..640696b8ae16
--- /dev/null
+++ b/virtual/wine/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ </maintainer>
+ <use>
+ <flag name="d3d9">Enable Ixit's Gallium Nine Patchset</flag>
+ <flag name="staging">Enable Wine-Staging's Patchset</flag>
+ </use>
+ <longdescription lang="en">
+ Allows for any variant of WINE, regardless of slotting to fulfill the dependencies
+ traditionally fulfilled by the non-slotted, pre-variant, app-emulation/wine.
+ </longdescription>
+</pkgmetadata>
diff --git a/virtual/wine/wine-0-r4.ebuild b/virtual/wine/wine-0-r4.ebuild
new file mode 100644
index 000000000000..37b7a7f5477d
--- /dev/null
+++ b/virtual/wine/wine-0-r4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Virtual for WINE that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="staging d3d9"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging]
+ app-emulation/wine-any[staging]
+ ) )
+ d3d9? ( || (
+ app-emulation/wine-d3d9[d3d9]
+ app-emulation/wine-any[d3d9]
+ ) )
+ || (
+ app-emulation/wine-vanilla
+ app-emulation/wine-staging
+ app-emulation/wine-d3d9
+ app-emulation/wine-any
+ )
+ !app-emulation/wine:0"