summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_h2/mod_h2-1.12.5.ebuild')
-rw-r--r--www-apache/mod_h2/mod_h2-1.12.5.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/www-apache/mod_h2/mod_h2-1.12.5.ebuild b/www-apache/mod_h2/mod_h2-1.12.5.ebuild
deleted file mode 100644
index 3e6d435d3f82..000000000000
--- a/www-apache/mod_h2/mod_h2-1.12.5.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit apache-module autotools
-
-MY_P="${PN/h2/http2}-${PV}"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
- inherit git-r3
-else
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="HTTP/2 module for Apache"
-HOMEPAGE="https://github.com/icing/mod_h2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="ssl"
-
-RDEPEND=">=net-libs/nghttp2-1.0
- >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
-DEPEND="${RDEPEND}"
-
-need_apache2_4
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
-
- APACHE2_MOD_DEFINE="HTTP2"
- insinto "${APACHE_MODULES_CONFDIR}"
- newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
-}