summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/Manifest1
-rw-r--r--www-apache/passenger/passenger-5.2.1.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index 350f2df103b7..4dd72d3da112 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1,3 +1,4 @@
DIST passenger-5.1.11.tar.gz 4243340 BLAKE2B 25c6cc0016c4078962466716f16a2d084d4e59528153bbe09dae70c4935941cabc456062e0004f7640074f163e53aa6f95e44fc7b99136292db5e3c9bb9fe554 SHA512 7dce496916533f2fcd5cb5931d79308da8adda300a8b8603ce90b92645e69a1283d147976b5aa3408f86ccb71f9e5849bfb68e58a806a8a58529cadda557bccb
DIST passenger-5.1.12.tar.gz 4245993 BLAKE2B 4f5808bcb373a85fbe2e160d9bd993fdff32a78f5083f5b5ff38112a4d3ca906a18a241cef6744350c0f33ef357dfda7a2cd5af875223a082a19b4e99cba4aeb SHA512 7ecdf0be306a3c4b842c8497861dbc072fc87f5601840678fe1125b77d50e683003b49616397d39b34705c967f604f5193be173c52a9c5ab235ef4e6e43f2f4a
DIST passenger-5.2.0.tar.gz 4978059 BLAKE2B d74e8a1b6ea21bf8ef2d606597acfe331661fc1d0908f0399c624c860700e004c3231f0fcd8adf4aec9221bcabb1311155b5ddc08cf8e92a6cb97736d87c8e97 SHA512 c1450f6921a75851d5ed1c8a34dc5dc97b085ee6ae2e5fcbaf897873c0f73af09ca1df1fa1986cb91937ea7b2192d222540b061c6c8e8bb03d19991b8b357e34
+DIST passenger-5.2.1.tar.gz 4978302 BLAKE2B 622f831e0b3e1a950f3dabc69b13c304896506d70341dafac0df4074450cea2b2c33a1c60b39efe8600a3cac32c6782f28599de85e1856a785896ada27f2f9c4 SHA512 8223fe0f7c04de9b079e8748d22679b7253599a5ef070cfd63b829c7ec7c4375528bc186d136ab2602d07a9a36fac4bc53b30c775e433641dfa80ab67f326848
diff --git a/www-apache/passenger/passenger-5.2.1.ebuild b/www-apache/passenger/passenger-5.2.1.ebuild
new file mode 100644
index 000000000000..1833c88aa150
--- /dev/null
+++ b/www-apache/passenger/passenger-5.2.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
+
+DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
+HOMEPAGE="https://www.phusionpassenger.com/"
+SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apache2 debug"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+ruby_add_rdepend "
+ >=dev-ruby/rack-1.0.0:*
+ >=dev-ruby/rake-0.8.1"
+
+# libev is bundled but with adapations that do not seem to be accepted
+# upstream, so we must use the bundled version :-(
+CDEPEND="
+ >=dev-libs/libuv-1.8.0
+ net-misc/curl[ssl]
+ apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
+
+RDEPEND="${RDEPEND} ${CDEPEND}"
+DEPEND="${DEPEND} ${CDEPEND}"
+
+APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
+APACHE2_MOD_DEFINE="PASSENGER"
+
+want_apache2
+
+pkg_setup() {
+ use debug && append-flags -DPASSENGER_DEBUG
+ depend.apache_pkg_setup
+}
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-5.1.1-isnan.patch
+
+ # Change these with sed instead of a patch so that we can easily use
+ # the toolchain-funcs methods.
+ sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
+ -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
+ -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
+
+ # Avoid fixed debugging CFLAGs.
+ sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
+
+ # Use sed here so that we can dynamically set the documentation directory.
+ sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
+ -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
+ src/ruby_supportlib/phusion_passenger.rb || die
+ sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
+
+ # Don't install a tool that won't work in our setup.
+ sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
+ rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
+
+ # Make sure we use the system-provided version where possible
+ rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
+
+ # Avoid building documentation to avoid a dependency on mizuho.
+ #sed -i -e 's/, :doc//' build/packaging.rb || die
+ touch doc/*.html || die
+
+ # Fix hard-coded use of AR
+ sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
+
+ # Make sure apache support is not attempted with -apache2
+ if ! use apache2 ; then
+ sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
+ fi
+}
+
+all_ruby_compile() {
+ if use apache2 ; then
+ V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ ruby -S rake apache2 || die "rake failed"
+ fi
+}
+
+each_ruby_compile() {
+ append-flags -fno-strict-aliasing
+
+ V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ ${RUBY} -S rake native_support || die "rake failed"
+}
+
+all_ruby_install() {
+ if use apache2 ; then
+ APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
+ apache-module_src_install
+
+ # Patch in the correct libdir
+ sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
+ fi
+
+ dodoc CHANGELOG README.md
+}
+
+each_ruby_install() {
+ DISTDIR="${D}" \
+ RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
+ RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
+ APXS2="${APXS}" \
+ HTTPD="${APACHE_BIN}" \
+ FS_LIBDIR='/usr/'$(get_libdir) \
+ EXTRA_LDFLAGS="${LDFLAGS}" \
+ USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
+ ${RUBY} -S rake fakeroot || die "rake failed"
+}