summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/Manifest4
-rw-r--r--www-apache/passenger/passenger-5.3.3.ebuild127
-rw-r--r--www-apache/passenger/passenger-5.3.4.ebuild127
-rw-r--r--www-apache/passenger/passenger-5.3.5.ebuild127
-rw-r--r--www-apache/passenger/passenger-5.3.6.ebuild127
5 files changed, 0 insertions, 512 deletions
diff --git a/www-apache/passenger/Manifest b/www-apache/passenger/Manifest
index dc3d7fd1a885..9a7daa087d35 100644
--- a/www-apache/passenger/Manifest
+++ b/www-apache/passenger/Manifest
@@ -1,6 +1,2 @@
DIST passenger-5.3.2.tar.gz 7039759 BLAKE2B be10b368530b8560d7d93664bbf91711ace0cadb0d1e15a978c0a52311a626ea2e1c6d05e507ef488b384e4a7ccc4b02da35bd5bd5878788b036401e06a33b5f SHA512 97900a0e0de67cc3c3770c291c85c6fe937fceab5632c9832bc5c461d3b4e586a47c9733a1a50a805834f591e5af90651789ed74bf74e0eed4d6ce8084c51967
-DIST passenger-5.3.3.tar.gz 7040055 BLAKE2B 1a9caa34dd809f96da84e9e3c00f365fd5a5e80c5134c25be810ad2bd9e1f01d0f64c6323211f28121590ac4d4593572c5f4392e1be2bc87d78741a0fdd73885 SHA512 ae0b4a2681e7877c7a57d236139033f17782f3d0d891ac58bbfec211e77e3ada9d36c250c9c9234d853c666d1501ccc0e2d5997c247f10985cad936ad97a741e
-DIST passenger-5.3.4.tar.gz 7201951 BLAKE2B bc67fc5a0a1a8a38918d5c36470cc9df888eb7b85304b06f283199692b18922a9077db11db374fded091f851d5af67e7852d662f0e22a7ac4d49381eae35cbf9 SHA512 08fa0b06ae85cd48c748739be77713752c989ef031910441c243b5beacef398d544c41c87faa05a4d3f088da048b20ff5923d368ca12e0e2fd815726e9ce8c1a
-DIST passenger-5.3.5.tar.gz 7217952 BLAKE2B 80fca5713590c73b7d6afa73b5d3e323188ba6496082d0203dd09ee7d52d9751c6780ef1f68cb646722973743dfecf3aa810019c68a3f3ff0220a42de84d4081 SHA512 3b892f5d86247913572eb28541625f62fc22efba907541f5d3ef8a2d3a7bc81b7d90d5789650353bb4f2e11184e9ac272ea3d954db20ad5c6f9c9bdc52d2d035
-DIST passenger-5.3.6.tar.gz 7198910 BLAKE2B 2044e76e3aa582a684954fcc773e17f2b395376e0f8a163b5e736c65e3d62ba90a96929b8d4a6a0244e628f43b7fcf02bb81e0279026d12da4c9cec7bced06bd SHA512 d5e8462b94dacdcb1b0381321b2edae2983c8d659bde3d50683759005cacc4f7c406ff6ca61bac5196463d066a948518834e535fe8943e974f20e1d0c3b429bd
DIST passenger-5.3.7.tar.gz 7195477 BLAKE2B 43a2384574316f6c8472f326389e8c1feed769e78d66c20e63f6d2679b1ac1b20a9122612c98e3006520e6f24c5883addd93ef11e8f0385759ee0c9e9299b7ad SHA512 bbef4881e0e0c698b29b10ff8a7afbc001c31d14fb80ffa27ed6867a92ad23712319733e6162be1f7720ebda421630af2f258f8167fa73c7b5ea594bc8247158
diff --git a/www-apache/passenger/passenger-5.3.3.ebuild b/www-apache/passenger/passenger-5.3.3.ebuild
deleted file mode 100644
index 7a2b4ba69962..000000000000
--- a/www-apache/passenger/passenger-5.3.3.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
- eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}
diff --git a/www-apache/passenger/passenger-5.3.4.ebuild b/www-apache/passenger/passenger-5.3.4.ebuild
deleted file mode 100644
index 7a2b4ba69962..000000000000
--- a/www-apache/passenger/passenger-5.3.4.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
- eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}
diff --git a/www-apache/passenger/passenger-5.3.5.ebuild b/www-apache/passenger/passenger-5.3.5.ebuild
deleted file mode 100644
index 3e6bbbe20254..000000000000
--- a/www-apache/passenger/passenger-5.3.5.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
- eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}
diff --git a/www-apache/passenger/passenger-5.3.6.ebuild b/www-apache/passenger/passenger-5.3.6.ebuild
deleted file mode 100644
index 3e6bbbe20254..000000000000
--- a/www-apache/passenger/passenger-5.3.6.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
-
-inherit apache-module flag-o-matic multilib ruby-ng toolchain-funcs
-
-DESCRIPTION="Passenger makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="https://www.phusionpassenger.com/"
-SRC_URI="https://s3.amazonaws.com/phusion-passenger/releases/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="apache2 debug"
-
-ruby_add_bdepend "dev-ruby/rake"
-
-ruby_add_rdepend "
- >=dev-ruby/rack-1.0.0:*
- >=dev-ruby/rake-0.8.1"
-
-# libev is bundled but with adapations that do not seem to be accepted
-# upstream, so we must use the bundled version :-(
-CDEPEND="
- >=dev-libs/libuv-1.8.0
- net-misc/curl[ssl]
- apache2? ( www-servers/apache[apache2_modules_unixd(+)] )"
-
-RDEPEND="${RDEPEND} ${CDEPEND}"
-DEPEND="${DEPEND} ${CDEPEND}"
-
-APACHE2_MOD_CONF="30_mod_${PN}-5.0.0 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-want_apache2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
- depend.apache_pkg_setup
-}
-
-all_ruby_prepare() {
- eapply "${FILESDIR}"/${PN}-5.1.11-gentoo.patch
- eapply "${FILESDIR}"/${PN}-5.1.1-isnan.patch
-
- # Change these with sed instead of a patch so that we can easily use
- # the toolchain-funcs methods.
- sed -i -e "/^CC/ s/=.*$/= '$(tc-getCC)'/" \
- -e "/^CXX\s/ s/=.*$/= '$(tc-getCXX)'/" \
- -e 's/PlatformInfo.debugging_cflags//' build/basics.rb || die
-
- # Avoid fixed debugging CFLAGs.
- sed -e '/debugging_cflags/areturn ""' -i src/ruby_supportlib/phusion_passenger/platform_info/compiler.rb || die
-
- # Use sed here so that we can dynamically set the documentation directory.
- sed -i -e "s:/usr/share/doc/passenger:/usr/share/doc/${P}:" \
- -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" \
- src/ruby_supportlib/phusion_passenger.rb || die
- sed -i -e "s:/usr/lib/phusion-passenger/agents:/usr/libexec/phusion-passenger/agents:" src/cxx_supportlib/ResourceLocator.h || die
-
- # Don't install a tool that won't work in our setup.
- sed -i -e '/passenger-install-apache2-module/d' src/ruby_supportlib/phusion_passenger/packaging.rb || die
- rm -f bin/passenger-install-apache2-module || die "Unable to remove unneeded install script."
-
- # Make sure we use the system-provided version where possible
- rm -rf src/cxx_supportlib/vendor-copy/libuv || die "Unable to remove vendored code."
-
- # Avoid building documentation to avoid a dependency on mizuho.
- #sed -i -e 's/, :doc//' build/packaging.rb || die
- touch doc/*.html || die
-
- # Fix hard-coded use of AR
- sed -i -e "s/ar cru/"$(tc-getAR)" cru/" build/support/cplusplus.rb || die
-
- # Make sure apache support is not attempted with -apache2
- if ! use apache2 ; then
- sed -i -e '/fakeroot/ s/:apache2, //' build/packaging.rb || die
- fi
-}
-
-all_ruby_compile() {
- if use apache2 ; then
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ruby -S rake apache2 || die "rake failed"
- fi
-}
-
-each_ruby_compile() {
- append-flags -fno-strict-aliasing
-
- V=1 EXTRA_LDFLAGS="${LDFLAGS}" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake native_support || die "rake failed"
-}
-
-all_ruby_install() {
- if use apache2 ; then
- APACHE2_MOD_FILE="${S}/buildout/apache2/mod_${PN}.so"
- apache-module_src_install
-
- # Patch in the correct libdir
- sed -i -e 's:/usr/lib/:/usr/'$(get_libdir)'/:' "${D}${APACHE_MODULES_CONFDIR}/30_mod_${PN}.conf" || die
- fi
-
- dodoc CHANGELOG README.md
-}
-
-each_ruby_install() {
- DISTDIR="${D}" \
- RUBYLIBDIR="$(ruby_rbconfig_value vendordir)" \
- RUBYARCHDIR="$(ruby_rbconfig_value archdir)" \
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- FS_LIBDIR='/usr/'$(get_libdir) \
- EXTRA_LDFLAGS="${LDFLAGS}" \
- USE_VENDORED_LIBUV="no" LIBUV_LIBS="-luv" \
- ${RUBY} -S rake fakeroot || die "rake failed"
-}