summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/netbox')
-rw-r--r--www-apps/netbox/Manifest1
-rw-r--r--www-apps/netbox/files/netbox-2.6.7-no-pip.patch32
-rw-r--r--www-apps/netbox/netbox-2.6.7.ebuild124
3 files changed, 157 insertions, 0 deletions
diff --git a/www-apps/netbox/Manifest b/www-apps/netbox/Manifest
index b76f4454a5e5..c60ca246557f 100644
--- a/www-apps/netbox/Manifest
+++ b/www-apps/netbox/Manifest
@@ -4,3 +4,4 @@ DIST netbox-2.6.1.tar.gz 2393902 BLAKE2B 027115458cbb873cb7aa7660a6cd1df46a7768d
DIST netbox-2.6.4.tar.gz 2408970 BLAKE2B 47fa3473e893e8443aace8b587df0065a3024a34f9509644deddce7c53e5ac8b3832df55604f3328d699f8f703ae15ad5b52312e1af8fcccabb7cd06377c8a09 SHA512 b137ec7f2d33bb7b48bcb38719ac9ea8cc31d7d38e33cedfb3279b8be2078c9a48ede10db1e4b4cab4a08c77e010060936e445cb6a1d2e6247bcc8d935cc9c3a
DIST netbox-2.6.5.tar.gz 2408180 BLAKE2B d119a1bf8256e0d6265eda7122a1d436ecb0e8e640acd12890d242c2c93768b21b5f8ebdbaecdfa31c0eaab0150edf52f08a1f424102fd940dd359bd8eafd4af SHA512 0b76e5bc3f56effbf7493680d10d549caf36e7769e21a2c24449cbe329379369f3428354c228d0cbbbc153dc62efb5c0e56c4a0d71c99f3267acd2446f48fb8a
DIST netbox-2.6.6.tar.gz 2414895 BLAKE2B b27e1bd5bf810627a4ec563b2eb5dbd7c86bf3d98e52555e511ee16492fd96a6cb7604dce8f5954120ab8b3a48d6acf7878721005bcfd2bd9e3880294dfbcd4d SHA512 9b44442cea1f76cdecb37faee8fe32012b869ff63c1b0bc678d2bb8624851941e9296854a9d85abea24e49a75fd5b31b968e4adbd56e5bc03a1c9f28fc8b846e
+DIST netbox-2.6.7.tar.gz 2416096 BLAKE2B 9c9744b60c3999fa7c3336539937cc20eebac67559444a4512cc4d69e8d38babc147254fd1fc49b8515203a8fd4411bc61c4c30aa3313e1ffe0d0e86abd8c9bb SHA512 63ed6a95a1f33ee5dd19dc2e43fc5c6aa09979c6f6856b28060992a8aaee956363caf20c48e72884adb84d260669d828311c0cf0d143fc0e58fed9677baf76db
diff --git a/www-apps/netbox/files/netbox-2.6.7-no-pip.patch b/www-apps/netbox/files/netbox-2.6.7-no-pip.patch
new file mode 100644
index 000000000000..a47e151c0842
--- /dev/null
+++ b/www-apps/netbox/files/netbox-2.6.7-no-pip.patch
@@ -0,0 +1,32 @@
+diff --git a/upgrade.sh b/upgrade.sh
+index d17dec06..6972ed2f 100755
+--- a/upgrade.sh
++++ b/upgrade.sh
+@@ -10,27 +10,6 @@ cd "$(dirname "$0")"
+ PYTHON="python3"
+ PIP="pip3"
+
+-# Uninstall any Python packages which are no longer needed
+-COMMAND="${PIP} uninstall -r old_requirements.txt -y"
+-echo "Removing old Python packages ($COMMAND)..."
+-eval $COMMAND
+-
+-# Install any new Python packages
+-COMMAND="${PIP} install -r requirements.txt --upgrade"
+-echo "Updating required Python packages ($COMMAND)..."
+-eval $COMMAND
+-
+-# Validate Python dependencies
+-COMMAND="${PIP} check"
+-echo "Validating Python dependencies ($COMMAND)..."
+-eval $COMMAND || (
+- echo "******** PLEASE FIX THE DEPENDENCIES BEFORE CONTINUING ********"
+- echo "* Manually install newer version(s) of the highlighted packages"
+- echo "* so that 'pip3 check' passes. For more information see:"
+- echo "* https://github.com/pypa/pip/issues/988"
+- exit 1
+-)
+-
+ # Apply any database migrations
+ COMMAND="${PYTHON} netbox/manage.py migrate"
+ echo "Applying database migrations ($COMMAND)..."
diff --git a/www-apps/netbox/netbox-2.6.7.ebuild b/www-apps/netbox/netbox-2.6.7.ebuild
new file mode 100644
index 000000000000..5058c6208136
--- /dev/null
+++ b/www-apps/netbox/netbox-2.6.7.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
+inherit python-single-r1 user readme.gentoo-r1
+
+DESCRIPTION="IP address and data center infrastructure management tool"
+HOMEPAGE="https://github.com/netbox-community/netbox"
+SRC_URI="https://github.com/netbox-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ldap webhooks"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/django-cacheops-4.1[${PYTHON_USEDEP}]
+ >=dev-python/django-cors-headers-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/django-debug-toolbar-2.0[${PYTHON_USEDEP}]
+ >=dev-python/django-filter-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/django-mptt-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/django-prometheus-1.0.15[${PYTHON_USEDEP}]
+ >=dev-python/django-tables2-2.0.6[${PYTHON_USEDEP}]
+ >=dev-python/django-taggit-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/django-taggit-serializer-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/django-timezone-field-3.0[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-3.9.4[${PYTHON_USEDEP}]
+ >=dev-python/drf-yasg-1.16.0[${PYTHON_USEDEP},validation]
+ >=dev-python/graphviz-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.6.11[${PYTHON_USEDEP}]
+ <dev-python/markdown-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.19[${PYTHON_USEDEP}]
+ >=dev-python/pillow-6.2.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.3[${PYTHON_USEDEP}]
+ >=dev-python/py-gfm-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ ldap? ( >=dev-python/django-auth-ldap-1.7[${PYTHON_USEDEP}] )
+ webhooks? ( >=dev-python/django-rq-2.1.0[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-pip.patch
+ )
+
+DISABLE_AUTOFORMATTING=YES
+DOC_CONTENTS="
+netbox is installed on your system. However, there are some manual steps
+you need to complete from the installation guide [1].
+
+On Gentoo, the configuration files you need to edit are located in
+/etc/netbox, not /opt/netbox as shown in the installation guide.
+
+If this is a new installation, please follow the installation guide
+other than this difference. Also, if you need ldap or webhooks, set the
+appropriate use flags when you emerge netbox to install the
+dependencies.
+
+Once that is done, you should be able to add the netbox service to the
+default runlevel and start it.
+
+If you have webhooks turned on, you should also add the netbox-rqworker
+service to the default runlevel and start it.
+
+If this is an upgrade, follow these instructions:
+
+Stop the netbox service. If the netbox-rqworker service is running,
+stop it as well.
+
+Next, run the upgrade script as described in the upgrading guide[2].
+
+Next, check for new configuration options and set them as appropriate
+for your system.
+
+Next, start the netbox service.
+
+Finally, if you are using webhooks, start the netbox-rqworker service.
+
+[1] https://netbox.readthedocs.io/en/stable/installation/
+[2] https://netbox.readthedocs.io/en/stable/installation/upgrading/
+"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_install() {
+ dodir /opt
+ cp -a ../${P} "${ED}"/opt
+ dosym ${P} /opt/netbox
+dosym ../../etc/netbox/gunicorn_config.py /opt/netbox/gunicorn_config.py
+ dosym ../../../../etc/netbox/configuration.py \
+ /opt/netbox/netbox/netbox/configuration.py
+ dodir /etc/netbox
+ insinto /etc/netbox
+ newins netbox/netbox/configuration.example.py configuration.py
+ doins "${FILESDIR}"/gunicorn_config.py
+ fowners -R netbox:netbox /etc/netbox /opt/${P}
+ fowners -h netbox:netbox /opt/netbox
+ fperms o= /etc/netbox/configuration.py /etc/netbox/gunicorn_config.py
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use webhooks &&
+ newinitd "${FILESDIR}"/${PN}-rqworker.initd ${PN}-rqworker
+ keepdir /var/log/netbox
+ fowners -R netbox:netbox /var/log/netbox
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ local r
+ for r in $REPLACING_VERSIONS; do
+ if [[ $r = "2.5.10" ]]; then
+ ewarn "The home directory of the netbox user is now /var/lib/netbox"
+ ewarn "Please adjust your system."
+ fi
+ done
+}