summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/zeppelin-bin')
-rw-r--r--www-apps/zeppelin-bin/Manifest1
-rw-r--r--www-apps/zeppelin-bin/files/zeppelin.init.d19
-rw-r--r--www-apps/zeppelin-bin/metadata.xml11
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild40
4 files changed, 71 insertions, 0 deletions
diff --git a/www-apps/zeppelin-bin/Manifest b/www-apps/zeppelin-bin/Manifest
new file mode 100644
index 000000000000..ae449ef71b1e
--- /dev/null
+++ b/www-apps/zeppelin-bin/Manifest
@@ -0,0 +1 @@
+DIST zeppelin-bin-0.8.1.tgz 992975720 BLAKE2B 13bae89054a5be0570d0550cfc875d989de66dcdc6fe2aa3c8b71b452782d8cf2c8f6cf030b47f1b9050899912f75136cef7d9ef1b80c8957ad8a260fc7050c5 SHA512 b8302b36acc5cc8859f4341329bcb4d038bbb91d4493be191606df94da08a2fa37940958ceae507e6cdbe22fc338111ac9bee580cb41ee74198911469552df02
diff --git a/www-apps/zeppelin-bin/files/zeppelin.init.d b/www-apps/zeppelin-bin/files/zeppelin.init.d
new file mode 100644
index 000000000000..03ddd6beabc7
--- /dev/null
+++ b/www-apps/zeppelin-bin/files/zeppelin.init.d
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+description="Web-based interactive data analytics notebook launcher"
+command="/opt/zeppelin/bin/zeppelin-daemon.sh"
+logfile="/var/log/zeppelin/zeppelin-gentoo.log"
+
+start() {
+ ebegin "Starting Apache Zeppelin ..."
+ bash $command start >> $logfile
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Apache Zeppelin ..."
+ bash $command stop >> $logfile
+ eend $?
+}
diff --git a/www-apps/zeppelin-bin/metadata.xml b/www-apps/zeppelin-bin/metadata.xml
new file mode 100644
index 000000000000..5c85a44abf8e
--- /dev/null
+++ b/www-apps/zeppelin-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">apache/zeppelin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
new file mode 100644
index 000000000000..6b80c178e624
--- /dev/null
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.8.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 user
+
+MY_PN="zeppelin"
+MY_P="${MY_PN}-${PV}-bin-all"
+
+DESCRIPTION="Web-based interactive data analytics notebook launcher"
+HOMEPAGE="https://zeppelin.apache.org"
+SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+RDEPEND=">=virtual/jre-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+INSTALL_DIR="/opt/${P}"
+
+pkg_setup() {
+ enewgroup zeppelin
+ enewuser zeppelin -1 /bin/sh /home/zeppelin zeppelin
+}
+
+src_install() {
+ keepdir /var/log/zeppelin
+ fowners -R zeppelin:zeppelin /var/log/zeppelin
+
+ newinitd "${FILESDIR}/zeppelin.init.d" zeppelin
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP * "${ED}/${INSTALL_DIR}" || die
+ dosym "${ED}/${INSTALL_DIR}" /opt/zeppelin
+ fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
+}