summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/cgp/Manifest1
-rw-r--r--www-apps/cgp/cgp-1.ebuild52
-rw-r--r--www-apps/cgp/cgp-1_p20180620.ebuild53
3 files changed, 0 insertions, 106 deletions
diff --git a/www-apps/cgp/Manifest b/www-apps/cgp/Manifest
index 9d92f0821556..cde99e2778b3 100644
--- a/www-apps/cgp/Manifest
+++ b/www-apps/cgp/Manifest
@@ -1,2 +1 @@
-DIST cgp-1.tar.gz 139265 BLAKE2B bf0f18def8ac3c2117b951172d4150f0626e8dcbe22accbcc6ad156e5f9f5c21792e38fa1bf5a964d8b50cbc7ee9003e4dcdcd75730ba2b0445f4dcfeffdda6c SHA512 fc5bc6d39dac896b56579cb6ca013c81493b994a7a190e0c0eec8a64f7b87c6eb2e0ad5cc969b8ea03ca4b00eee212ccee5c8785c23f5656bff3fe5490ff8f75
DIST cgp-1_p20180620.tar.gz 139549 BLAKE2B 2cc1a416ae1158b5788615b05bf43039049af52eb5296e7fd8136c9895e8ee0a9887e84ad37c6598a4c4387982a2860fbdb7cf9cdff39cfe5bbee598b9ace88f SHA512 acd09bb699af678347dacfc08fee60a86843874543851805f245952e538777d7ccd528c156f7a21b803503c7aac134013a4eb8200d5266cf35541b0dce5839e4
diff --git a/www-apps/cgp/cgp-1.ebuild b/www-apps/cgp/cgp-1.ebuild
deleted file mode 100644
index 0d1bc985b145..000000000000
--- a/www-apps/cgp/cgp-1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_PN="${PN^^}"
-
-DESCRIPTION="A graphical web-based front-end for visualizing RRD collected by collectd"
-HOMEPAGE="https://github.com/pommi/CGP
- https://pommi.nethuis.nl/category/cgp/"
-SRC_URI="https://github.com/pommi/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="CC-BY-2.0 GPL-2+ GPL-3 MIT"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-lang/php[json]
- net-analyzer/rrdtool[graph]
- virtual/httpd-php"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-DOCS=( "README.md" "doc/CHANGELOG" "doc/nginx.conf" )
-
-src_install() {
- webapp_src_preinst
-
- einstalldocs
-
- # Since the docs are already installed, remove them from htdocs
- # The file doc/CHANGELOG is needed, as CGP reads from there it's version
- rm -r .gitignore doc/LICENSE doc/nginx.conf || die
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- einfo "The command shell_exec must not be disabled"
- einfo "through the disable_functions php.ini directive."
- einfo "It must allow execution of the rrdtool program."
- einfo ""
- einfo "An configuration file for www-servers/nginx"
- einfo "has been installed as an example."
-}
diff --git a/www-apps/cgp/cgp-1_p20180620.ebuild b/www-apps/cgp/cgp-1_p20180620.ebuild
deleted file mode 100644
index 6051624a6a90..000000000000
--- a/www-apps/cgp/cgp-1_p20180620.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_PN="${PN^^}"
-MY_PV="1920ca24a067ac157a6bd8f3c017f4c6244ae245"
-
-DESCRIPTION="A graphical web-based front-end for visualizing RRD collected by collectd"
-HOMEPAGE="https://github.com/pommi/CGP
- https://pommi.nethuis.nl/category/cgp/"
-SRC_URI="https://github.com/pommi/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="CC-BY-2.0 GPL-2+ GPL-3 MIT"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-lang/php[json]
- net-analyzer/rrdtool[graph]
- virtual/httpd-php"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${MY_PN}-${MY_PV}"
-
-DOCS=( "README.md" "doc/CHANGELOG" "doc/nginx.conf" )
-
-src_install() {
- webapp_src_preinst
-
- einstalldocs
-
- # Since the docs are already installed, remove them from htdocs
- # The file doc/CHANGELOG is needed, as CGP reads from there it's version
- rm -r .gitignore doc/LICENSE doc/nginx.conf || die
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
-
- einfo "The command shell_exec must not be disabled"
- einfo "through the disable_functions php.ini directive."
- einfo "It must allow execution of the rrdtool program."
- einfo ""
- einfo "An configuration file for www-servers/nginx"
- einfo "has been installed as an example."
-}