summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch26
-rw-r--r--www-client/seamonkey/seamonkey-2.53.3.ebuild5
2 files changed, 18 insertions, 13 deletions
diff --git a/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch b/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch
index e2c6aa20161b..8aee245ef18f 100644
--- a/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch
+++ b/www-client/seamonkey/files/seamonkey-2.53.3-rust-1.45.0.patch
@@ -1,15 +1,23 @@
---- seamonkey-2.53.3/mozilla/config/rules.mk
-+++ seamonkey-2.53.3/mozilla/config/rules.mk
-@@ -871,12 +871,6 @@
+--- a/mozilla/config/rules.mk
++++ b/mozilla/config/rules.mk
+@@ -870,16 +870,20 @@ endif
+
# These flags are passed via `cargo rustc` and only apply to the final rustc
# invocation (i.e., only the top-level crate, not its dependencies).
cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
--ifndef DEVELOPER_OPTIONS
--ifndef MOZ_DEBUG_RUST
--# Enable link-time optimization for release builds.
--cargo_rustc_flags += -C lto
--endif
--endif
+ ifndef DEVELOPER_OPTIONS
+ ifndef MOZ_DEBUG_RUST
+ # Enable link-time optimization for release builds.
+ cargo_rustc_flags += -C lto
++# Versions of rust >= 1.45 need -Cembed-bitcode=yes for all crates when using -Clto.
++ifeq (,$(filter 1.3% 1.40.% 1.41.% 1.42.% 1.43.% 1.44.%,$(RUSTC_VERSION)))
++RUSTFLAGS += -Cembed-bitcode=yes
++endif
+ endif
+ endif
rustflags_override = RUSTFLAGS='$(MOZ_RUST_DEFAULT_FLAGS) $(RUSTFLAGS)'
+ ifdef MOZ_MSVCBITS
+ # If we are building a MozillaBuild shell, we want to clear out the
+ # vcvars.bat environment variables for cargo builds. This is because
diff --git a/www-client/seamonkey/seamonkey-2.53.3.ebuild b/www-client/seamonkey/seamonkey-2.53.3.ebuild
index c81cbe49b6a7..b05ff561d50f 100644
--- a/www-client/seamonkey/seamonkey-2.53.3.ebuild
+++ b/www-client/seamonkey/seamonkey-2.53.3.ebuild
@@ -189,10 +189,7 @@ src_prepare() {
edos2unix "${file}"
done
- if has_version ">=virtual/rust-1.45.0" ; then
- einfo "Unbreak build with >=rust-1.45.0, bmo#1640982 ..."
- eapply "${FILESDIR}/${PN}-2.53.3-rust-1.45.0.patch"
- fi
+ eapply "${FILESDIR}/${PN}-2.53.3-rust-1.45.0.patch"
# Allow user to apply any additional patches without modifing ebuild
eapply_user