summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/tangram/files')
-rw-r--r--www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch11
-rw-r--r--www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch11
2 files changed, 22 insertions, 0 deletions
diff --git a/www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch b/www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch
new file mode 100644
index 000000000000..4f636213c70b
--- /dev/null
+++ b/www-client/tangram/files/tangram-2.0-dont-validate-appstream.patch
@@ -0,0 +1,11 @@
+--- a/data/appdata/meson.build
++++ b/data/appdata/meson.build
+@@ -7,7 +7,7 @@ appstream_file = i18n.merge_file(
+ )
+
+ appstream_util = find_program('appstream-util', required: false)
+-if appstream_util.found()
++if false
+ test('Validate appstream file', appstream_util,
+ args: ['validate', appstream_file]
+ )
diff --git a/www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch b/www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch
new file mode 100644
index 000000000000..1ea82d214aee
--- /dev/null
+++ b/www-client/tangram/files/tangram-2.0-meson-blueprint-compiler.patch
@@ -0,0 +1,11 @@
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -5,7 +5,7 @@ blueprint_compiler = find_program(
+ # Flatpak
+ '/app/bin/blueprint-compiler',
+ # host
+- '../blueprint-compiler/blueprint-compiler.py'
++ 'blueprint-compiler'
+ )
+
+ gjspack = find_program('../troll/gjspack/bin/gjspack')