summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/zoneminder/files')
-rw-r--r--www-misc/zoneminder/files/10_zoneminder.conf-r117
-rw-r--r--www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch34
-rw-r--r--www-misc/zoneminder/files/zoneminder-1.28.1-mysql_include_path.patch20
3 files changed, 0 insertions, 71 deletions
diff --git a/www-misc/zoneminder/files/10_zoneminder.conf-r1 b/www-misc/zoneminder/files/10_zoneminder.conf-r1
deleted file mode 100644
index 441c793d1890..000000000000
--- a/www-misc/zoneminder/files/10_zoneminder.conf-r1
+++ /dev/null
@@ -1,17 +0,0 @@
-ScriptAlias /zm/cgi-bin/ "/usr/libexec/zoneminder/cgi-bin/"
-
-<Directory "/usr/libexec/zoneminder/cgi-bin">
- AllowOverride All
- Options ExecCGI
- Order allow,deny
- Allow from all
-</Directory>
-
-Alias /zoneminder "%ZM_WEBDIR%"
-
-<Directory "%ZM_WEBDIR%">
- Options -Indexes MultiViews FollowSymLinks
- AllowOverride All
- Order allow,deny
- Allow from all
-</Directory>
diff --git a/www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch b/www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch
deleted file mode 100644
index 266bd649baa6..000000000000
--- a/www-misc/zoneminder/files/zoneminder-1.26.5-automagic.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 83e9d81..8619c8b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -171,6 +171,7 @@ else(PCRE_LIBRARIES)
- set(optlibsnotfound "${optlibsnotfound} PCRE")
- endif(PCRE_LIBRARIES)
-
-+if(HAVE_GCRYPT)
- # gcrypt (using find_library and find_path)
- find_library(GCRYPT_LIBRARIES gcrypt)
- if(GCRYPT_LIBRARIES)
-@@ -187,7 +188,11 @@ if(GCRYPT_LIBRARIES)
- else(GCRYPT_LIBRARIES)
- set(optlibsnotfound "${optlibsnotfound} GCrypt")
- endif(GCRYPT_LIBRARIES)
-+else(HAVE_GCRYPT)
-+ set(optlibsnotfound "${optlibsnotfound} GCrypt")
-+endif(HAVE_GCRYPT)
-
-+if(HAVE_GNUTLS)
- # gnutls (using find_library and find_path)
- find_library(GNUTLS_LIBRARIES gnutls)
- if(GNUTLS_LIBRARIES)
-@@ -205,6 +210,9 @@ if(GNUTLS_LIBRARIES)
- else(GNUTLS_LIBRARIES)
- set(optlibsnotfound "${optlibsnotfound} GnuTLS")
- endif(GNUTLS_LIBRARIES)
-+else(HAVE_GNUTLS)
-+ set(optlibsnotfound "${optlibsnotfound} GnuTLS")
-+endif(HAVE_GNUTLS)
-
- # mysqlclient (using find_library and find_path)
- find_library(MYSQLCLIENT_LIBRARIES mysqlclient PATH_SUFFIXES mysql)
diff --git a/www-misc/zoneminder/files/zoneminder-1.28.1-mysql_include_path.patch b/www-misc/zoneminder/files/zoneminder-1.28.1-mysql_include_path.patch
deleted file mode 100644
index cb645528c051..000000000000
--- a/www-misc/zoneminder/files/zoneminder-1.28.1-mysql_include_path.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/CMakeLists.txt 2015-10-27 17:28:48.059203421 +0000
-+++ b/CMakeLists.txt 2015-10-27 17:30:11.951226715 +0000
-@@ -255,7 +255,16 @@
- if(MYSQLCLIENT_LIBRARIES)
- set(HAVE_LIBMYSQLCLIENT 1)
- list(APPEND ZM_BIN_LIBS "${MYSQLCLIENT_LIBRARIES}")
-- find_path(MYSQLCLIENT_INCLUDE_DIR mysql/mysql.h)
-+ find_file(MYSQL_CONFIG mysql_config)
-+ if(MYSQL_CONFIG)
-+ execute_process(COMMAND ${MYSQL_CONFIG}
-+ --variable=pkgincludedir OUTPUT_VARIABLE
-+ MYSQLCLIENT_INCLUDE_DIR)
-+ STRING(REGEX REPLACE "\n" "" MYSQLCLIENT_INCLUDE_DIR
-+ ${MYSQLCLIENT_INCLUDE_DIR})
-+ else()
-+ find_path(MYSQLCLIENT_INCLUDE_DIR mysql/mysql.h)
-+ endif()
- if(MYSQLCLIENT_INCLUDE_DIR)
- include_directories("${MYSQLCLIENT_INCLUDE_DIR}")
- set(CMAKE_REQUIRED_INCLUDES "${MYSQLCLIENT_INCLUDE_DIR}")