summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/freshplayerplugin/files')
-rw-r--r--www-plugins/freshplayerplugin/files/0.3.5-cmake.patch70
-rw-r--r--www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch11
-rw-r--r--www-plugins/freshplayerplugin/files/freshplayerplugin-0.3.9-ffmpeg-4.patch74
3 files changed, 0 insertions, 155 deletions
diff --git a/www-plugins/freshplayerplugin/files/0.3.5-cmake.patch b/www-plugins/freshplayerplugin/files/0.3.5-cmake.patch
deleted file mode 100644
index f925dfa31eb9..000000000000
--- a/www-plugins/freshplayerplugin/files/0.3.5-cmake.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -uarN a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2015-04-25 11:17:24.000000000 -0400
-+++ b/CMakeLists.txt 2015-04-26 20:14:43.152014529 -0400
-@@ -61,35 +61,36 @@
- # optional dependencies
- message(STATUS "checking for optional dependencies")
-
--pkg_check_modules(PULSEAUDIO QUIET libpulse)
--pkg_check_modules(JACK QUIET jack)
--pkg_check_modules(SOXR QUIET soxr)
- set(WITH_PULSEAUDIO TRUE CACHE STRING "enable PulseAudio support")
- set(WITH_JACK TRUE CACHE STRING "enable JACK Audio Connection Kit")
-
--if (PULSEAUDIO_FOUND AND WITH_PULSEAUDIO)
-+if (WITH_PULSEAUDIO)
-+ pkg_check_modules(PULSEAUDIO libpulse)
-+ if (NOT PULSEAUDIO_FOUND)
-+ message(FATAL_ERROR "PulseAudio requested but not found.")
-+ endif()
- add_definitions(-DHAVE_PULSEAUDIO=1)
-- message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION} (optional)")
-+ message(STATUS " found libpulse, version ${PULSEAUDIO_VERSION}")
- list(APPEND REQ_LIBRARY_DIRS ${PULSEAUDIO_LIBRARY_DIRS})
- list(APPEND REQ_INCLUDE_DIRS ${PULSEAUDIO_INCLUDE_DIRS})
- list(APPEND REQ_LIBRARIES ${PULSEAUDIO_LIBRARIES})
--else()
-- message(STATUS " no libpulse found (optional)")
- endif()
-
--if (JACK_FOUND AND WITH_JACK)
-- message(STATUS " found jack, version ${JACK_VERSION} (optional)")
-- if (SOXR_FOUND)
-- message(STATUS " found soxr, version ${SOXR_VERSION}")
-- add_definitions(-DHAVE_JACK=1)
-- list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
-- list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
-- list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
-- else()
-- message(STATUS " no soxr found, JACK output disabled")
-+if (WITH_JACK)
-+ pkg_check_modules(JACK QUIET jack)
-+ if (NOT JACK_FOUND)
-+ message(FATAL_ERROR "JACK support requested but not found.")
-+ endif()
-+ pkg_check_modules(SOXR QUIET soxr)
-+ if (NOT SOXR_FOUND)
-+ message(FATAL_ERROR "SOXR libray not found but needed for JACK support.")
- endif()
--else()
-- message(STATUS " no jack found (optional)")
-+ message(STATUS " found jack, version ${JACK_VERSION}")
-+ message(STATUS " found soxr, version ${SOXR_VERSION}")
-+ add_definitions(-DHAVE_JACK=1)
-+ list(APPEND REQ_LIBRARY_DIRS "${JACK_LIBRARY_DIRS}" "${SOXR_LIBRARY_DIRS}")
-+ list(APPEND REQ_INCLUDE_DIRS "${JACK_INCLUDE_DIRS}" "${SOXR_INCLUDE_DIRS}")
-+ list(APPEND REQ_LIBRARIES "${JACK_LIBRARIES}" "${SOXR_LIBRARIES}")
- endif()
-
- list(APPEND REQ_LIBRARIES img-resources)
---- a/src/CMakeLists.txt 2015-12-20 08:38:33.000000000 -0500
-+++ b/src/CMakeLists.txt 2015-12-26 20:45:07.000000000 -0500
-@@ -5,7 +5,7 @@
-
- set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
-
--set(MOZPLUGIN_INSTALL_DIR "lib${LIB_SUFFIX}/mozilla/plugins/" CACHE STRING "plugin install directory")
-+set(MOZPLUGIN_INSTALL_DIR "lib${LIB_SUFFIX}/nsbrowser/plugins/" CACHE STRING "plugin install directory")
-
- add_subdirectory(uri_parser)
- add_subdirectory(config_parser)
diff --git a/www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch b/www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch
deleted file mode 100644
index 112b839016f9..000000000000
--- a/www-plugins/freshplayerplugin/files/0.3.9-ioctl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aurN a/src/ppb_video_capture.c b/src/ppb_video_capture.c
---- a/src/ppb_video_capture.c 2017-12-23 09:34:01.000000000 -0500
-+++ b/src/ppb_video_capture.c 2018-01-10 20:03:05.498415644 -0500
-@@ -75,6 +75,7 @@
-
- #if !HAVE_LIBV4L2
- // define simple wrappers, if libv4l2 is not used
-+#include <sys/ioctl.h>
- static
- ssize_t
- v4l2_read(int fd, void *buffer, size_t n)
diff --git a/www-plugins/freshplayerplugin/files/freshplayerplugin-0.3.9-ffmpeg-4.patch b/www-plugins/freshplayerplugin/files/freshplayerplugin-0.3.9-ffmpeg-4.patch
deleted file mode 100644
index 15d713bc4e90..000000000000
--- a/www-plugins/freshplayerplugin/files/freshplayerplugin-0.3.9-ffmpeg-4.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 934aa9c24d34f8203744b56e4ac6e8599446ca02 Mon Sep 17 00:00:00 2001
-From: Rinat Ibragimov <ibragimovrinat@mail.ru>
-Date: Tue, 26 Dec 2017 16:16:39 +0300
-Subject: [PATCH] ppb_video_decoder: use AV_ prefixed macros
-
-Looks like newer FFmpeg versions have droped old definitions.
----
- cmake/ffmpeg-compat/CMakeLists.txt | 1 +
- cmake/ffmpeg-compat/cfg_avcodecflags.c | 4 ++++
- cmake/ffmpeg-compat/ffmpeg_compat.h.in | 1 +
- src/ppb_video_decoder.c | 11 ++++++++---
- 4 files changed, 14 insertions(+), 3 deletions(-)
- create mode 100644 cmake/ffmpeg-compat/cfg_avcodecflags.c
-
-diff --git a/cmake/ffmpeg-compat/CMakeLists.txt b/cmake/ffmpeg-compat/CMakeLists.txt
-index 732a71ee..8f67c581 100644
---- a/cmake/ffmpeg-compat/CMakeLists.txt
-+++ b/cmake/ffmpeg-compat/CMakeLists.txt
-@@ -29,6 +29,7 @@ MACRO_C_SOURCE_CHECK(cfg_av_pix_fmt_vdpau.c HAVE_AV_PIX_FMT_VDPAU)
- MACRO_C_SOURCE_CHECK(cfg_avcodecid.c HAVE_AVCodecID)
- MACRO_C_SOURCE_CHECK(cfg_avcodeccontext_get_buffer2.c HAVE_AVCodecContext_get_buffer2)
- MACRO_C_SOURCE_CHECK(cfg_AVVDPAUContext.c HAVE_AVVDPAUContext)
-+MACRO_C_SOURCE_CHECK(cfg_avcodecflags.c HAVE_AV_CODEC_FLAGS)
-
- MACRO_SYMBOL_CHECK(av_frame_alloc "libavcodec/avcodec.h" HAVE_av_frame_alloc)
- MACRO_SYMBOL_CHECK(av_frame_free "libavcodec/avcodec.h" HAVE_av_frame_free)
-diff --git a/cmake/ffmpeg-compat/cfg_avcodecflags.c b/cmake/ffmpeg-compat/cfg_avcodecflags.c
-new file mode 100644
-index 00000000..d04de55b
---- /dev/null
-+++ b/cmake/ffmpeg-compat/cfg_avcodecflags.c
-@@ -0,0 +1,4 @@
-+#include <libavcodec/avcodec.h>
-+int main(void) {
-+ return AV_CODEC_FLAG_TRUNCATED + AV_CODEC_CAP_TRUNCATED;
-+}
-diff --git a/cmake/ffmpeg-compat/ffmpeg_compat.h.in b/cmake/ffmpeg-compat/ffmpeg_compat.h.in
-index dd40922c..da7834b1 100644
---- a/cmake/ffmpeg-compat/ffmpeg_compat.h.in
-+++ b/cmake/ffmpeg-compat/ffmpeg_compat.h.in
-@@ -6,3 +6,4 @@
- #define HAVE_av_frame_free (@HAVE_av_frame_free@)
- #define HAVE_avcodec_free_context (@HAVE_avcodec_free_context@)
- #define HAVE_AVVDPAUContext (@HAVE_AVVDPAUContext@)
-+#define HAVE_AV_CODEC_FLAGS (@HAVE_AV_CODEC_FLAGS@)
-diff --git a/src/ppb_video_decoder.c b/src/ppb_video_decoder.c
-index eb150725..23647cdd 100644
---- a/src/ppb_video_decoder.c
-+++ b/src/ppb_video_decoder.c
-@@ -70,6 +70,11 @@
- #define AV_CODEC_ID_H264 CODEC_ID_H264
- #endif // !HAVE_AVCodecID
-
-+#if !HAVE_AV_CODEC_FLAGS
-+#define AV_CODEC_CAP_TRUNCATED CODEC_CAP_TRUNCATED
-+#define AV_CODEC_FLAG_TRUNCATED CODEC_FLAG_TRUNCATED
-+#endif // !HAVE_AV_CODEC_FLAGS
-+
- enum hwdec_api_e {
- HWDEC_NONE = 0,
- HWDEC_VAAPI,
-@@ -620,9 +625,9 @@ initialize_decoder(struct pp_video_decoder_s *vd)
- goto err;
- }
-
-- if (vd->avcodec->capabilities & CODEC_CAP_TRUNCATED) {
-- trace_info("%s, codec have CODEC_CAP_TRUNCATED\n", __func__);
-- vd->avctx->flags |= CODEC_FLAG_TRUNCATED;
-+ if (vd->avcodec->capabilities & AV_CODEC_CAP_TRUNCATED) {
-+ trace_info("%s, codec have AV_CODEC_CAP_TRUNCATED\n", __func__);
-+ vd->avctx->flags |= AV_CODEC_FLAG_TRUNCATED;
- }
-
- vd->avctx->opaque = vd;