summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/passff')
-rw-r--r--www-plugins/passff/Manifest1
-rw-r--r--www-plugins/passff/passff-1.5.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/www-plugins/passff/Manifest b/www-plugins/passff/Manifest
index 020445e5515c..eb836493b170 100644
--- a/www-plugins/passff/Manifest
+++ b/www-plugins/passff/Manifest
@@ -1 +1,2 @@
DIST passff-1.3-an+fx-linux.xpi 59512 BLAKE2B 48eb41e8be2e090aa32137fe93eb6cb7a22218f865f1ade4e6f4516ea3fedc34333f43438fd7c96817ec695ca1d0ced9cff0dd53157e06442e000c12a4bff33c SHA512 d5e5c29fda852c08908ce27e55bb2cd3daaacedf4f1375eb626cf4228d9b8c5113d2210578d80420c1df3846cbb948c184702274ece851c9e8279000e38989a6
+DIST passff-1.5.1-an+fx-linux.xpi 64094 BLAKE2B ebe19e26db05ca38f7ede9a01c1abaec786c197c6a25f0f144be903a93b85723bd143ad1805090fcfe81e83289a156f818d7b7b2a5462f151eb0ac12d1e82b0e SHA512 23dc3833c2d83181c21955169e5f65df88a4a26ab018a852d1181b84fd338a40f46b8ed5828f0e1fccca72f610facac68ceb766a3a7b454962228c36bde233f7
diff --git a/www-plugins/passff/passff-1.5.1.ebuild b/www-plugins/passff/passff-1.5.1.ebuild
new file mode 100644
index 000000000000..8e1bdf3fe70f
--- /dev/null
+++ b/www-plugins/passff/passff-1.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mozextension
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/1056515/passff-1.5.1-an+fx-linux.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="firefox firefox-bin"
+
+RDEPEND="www-plugins/passff-host[firefox]"
+REQUIRED_USE="|| ( firefox firefox-bin )"
+
+S="${WORKDIR}"
+
+MY_XPINAME="passff-1.5.1-an+fx-linux"
+
+src_unpack() {
+ xpi_unpack "${MY_XPINAME}.xpi"
+}
+
+src_install() {
+ local MOZILLA_FIVE_HOME
+ if use firefox; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
+ xpi_install "${MY_XPINAME}"
+ fi
+
+ if use firefox-bin; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${MY_XPINAME}"
+ fi
+}