summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/passff/Manifest1
-rw-r--r--www-plugins/passff/passff-1.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/www-plugins/passff/Manifest b/www-plugins/passff/Manifest
index 25af54a823f5..0cfd5cf3ac07 100644
--- a/www-plugins/passff/Manifest
+++ b/www-plugins/passff/Manifest
@@ -1 +1,2 @@
DIST passff-1.8-fx.xpi 72678 BLAKE2B d5ec67fff396d62960fbf813ab9d8f6086028a282bab78aa4dc6e63132e723ce4b1bb6d05015d3934fabbd37460d04f7626043b97fd29c5c72486754ef14e111 SHA512 5500e7439d5eda3481eaa405abaef5b846f4f29b5fee4dffc49084b2ce658f9e13e4ced747a28d368892034921a556e3a989c1f8682365cdab787e41913c8250
+DIST passff-1.9-fx.xpi 72849 BLAKE2B 8b75fba4b5aeb04693966e74761e3ffb46512c83cfd27354c7e3e5c3ef83b9ea5eb7f53501e694a2e61157bb6b9c5ec62a6fcc9a5b81ef61d927a1a563f08671 SHA512 7810d97c1b5b5dc341684dceaac85f1d225880ea5d308a3eb72c807fa073f60f87abec0a6933d7918e565797c6eda9a78867d0edd33e90a6ccd5c8d1cbf80850
diff --git a/www-plugins/passff/passff-1.9.ebuild b/www-plugins/passff/passff-1.9.ebuild
new file mode 100644
index 000000000000..d2745055d54f
--- /dev/null
+++ b/www-plugins/passff/passff-1.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_XPINAME="${P}-fx"
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="https://addons.mozilla.org/firefox/downloads/file/3051801/${MY_XPINAME}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="www-plugins/passff-host[firefox]"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${MY_XPINAME}.xpi" . || die
+}
+
+src_install() {
+ # See https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons#Installation_using_the_standard_extension_folders
+ insinto "/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/"
+ # passff@invicem.pro is the extension id found in the manifest.json
+ newins "${MY_XPINAME}.xpi" "passff@invicem.pro.xpi"
+}