summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/chrome-binary-plugins/Manifest1
-rw-r--r--www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3902.4_alpha.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/www-plugins/chrome-binary-plugins/Manifest b/www-plugins/chrome-binary-plugins/Manifest
index 9942e4ad71e1..ef80e6937fd8 100644
--- a/www-plugins/chrome-binary-plugins/Manifest
+++ b/www-plugins/chrome-binary-plugins/Manifest
@@ -1,3 +1,2 @@
DIST google-chrome-beta_77.0.3865.75-1_amd64.deb 64103536 BLAKE2B 443200b8c821ed9c239fef08a8d97338033629bf2c5227240056d35a3a946fb97fe2b538a2e2d9fb14c01364c6ce59a82dc684eb522107dc129540c093d158b1 SHA512 524924bb88d601e86824067c6f4deca436e0af9d7d30ba68d2f2a857625c75ada8808dc3907dadd87a7a44ce88efb9dd058084be1a70c0f93142c041f4736d7a
DIST google-chrome-stable_77.0.3865.75-1_amd64.deb 62302944 BLAKE2B d4231928ff823e5c89339ff8327d9851b89f52761d9a8998f077535183476b6f39b948ac2604e4e3631b20ef25f985fb1d3fad0f7ea00ca97aba5fb58868a80d SHA512 b239fbf5549da67d900a605a62999900f9f3c8cd2f4ad9c55dcc91b20fda351ba82845ee908cc17daa8678ddacc01a3b2795adccf075ce22c9811667c3ca3216
-DIST google-chrome-unstable_78.0.3902.4-1_amd64.deb 62088460 BLAKE2B 45fbcdf6664266179f0a1404e573b04b947899b6b3fc8c1463c1ccdddcee09e3102a6813686f9131918adab2bf41906b9d0c3032517c53677e6ae6582d6e29cb SHA512 4b98a0deeaa4a3c5266a7a1eafd84dc7ec6d21219abf095750aaba067db1877ee91ac30190954a746db313c07e9c55e90e67ab25d9cb2266c5bc5db160ea66e5
diff --git a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3902.4_alpha.ebuild b/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3902.4_alpha.ebuild
deleted file mode 100644
index 3fd84e77d226..000000000000
--- a/www-plugins/chrome-binary-plugins/chrome-binary-plugins-78.0.3902.4_alpha.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2012-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib unpacker
-
-DESCRIPTION="Binary plugins from Google Chrome for use in Chromium"
-HOMEPAGE="https://www.google.com/chrome"
-
-case ${PV} in
- *_alpha*)
- SLOT="unstable"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_alpha}-1
- ;;
- *_beta*)
- SLOT="beta"
- CHROMEDIR="opt/google/chrome-${SLOT}"
- MY_PV=${PV%_beta}-1
- ;;
- *)
- SLOT="stable"
- CHROMEDIR="opt/google/chrome"
- MY_PV=${PV}-1
- ;;
-esac
-
-MY_PN="google-chrome-${SLOT}"
-MY_P="${MY_PN}_${MY_PV}"
-
-SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
-KEYWORDS="-* ~amd64"
-
-LICENSE="google-chrome"
-IUSE="+widevine"
-RESTRICT="bindist mirror strip"
-
-RDEPEND="
- widevine? (
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- !<www-client/chromium-57[widevine(-)]
- )
-"
-
-for x in 0 beta stable unstable; do
- if [[ ${SLOT} != ${x} ]]; then
- RDEPEND+=" !${CATEGORY}/${PN}:${x}"
- fi
-done
-
-S="${WORKDIR}/${CHROMEDIR}"
-QA_PREBUILT="*"
-
-pkg_nofetch() {
- eerror "Please wait 24 hours and sync your portage tree before reporting fetch failures."
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/chromium
- if use widevine; then
- doins libwidevinecdm.so
- dosym ../chromium/libwidevinecdm.so /usr/$(get_libdir)/chromium-browser/libwidevinecdm.so
- fi
-}